3

I have been having failures to install SQL Server 2012 SP2 on a 2-node active\passive cluster. I have uploaded detail and summary logs for the latest run on the passive node here: https://www.dropbox.com/s/4tlmv3hmzvbb9l4/Log%20Files.7z?dl=0

Due to not being able to pinpoint the error I have tried the following:

  • rebooting and running the patching from the GUI and command line with and without pre-extracting the files.
  • I have also ensured cluster services and SQL role are on the same active node, and brought the Available Storage group online although it does not have any unassigned disks in.
  • I have also ensured all default directories are present on the shared disks, and checked the registry for any features which are pending an update. I did not find any as I had seen reference to these problems.
  • I have also tried using 2 different admin accounts to run the setup even though I could not see any evidence of this problem

The GUI mimics the detail log showing all verification successful, the patching start; whereby after the patching begins it then ends with no error message. A completely blank feature list box is shown and a blank text box for log file locations, although these are obviously generated in the default location.

It seems to me the patching starts, but fails before any features begin to update without a specific error.

Any guidance is greatly appreciated.

  • Have you tried downloaded the Service Pack 2 installation again, possibly the media is corrupt based on the error code 5495 in your Summary.txt file.? – user507 Aug 6 '15 at 4:51
  • Hi Shawn, The same file was used to successfully patch a standalone server. I have also tried re-downloading a second copy from the Microsoft website but this fails in the same way – Chris Aug 6 '15 at 7:09
  • Your summary log states that the shared features patch is what failed. When you look at the screen that shows you what the current build is and what will be installed, is the instance checked? What does the SqlSetup.log show? – user507 Aug 6 '15 at 12:44
1

Figured out the problem last weekend. After trying to run a repair on my SQL Server 2012, it reported that the user Administrator doesn't have the proper privileges in order to proceed with the installation, so I had to do the following:

Provide Full Control through Group Policy Management Editor in Computer configurations -> Policies -> Windows Settings -> Security Settings -> Local Policies -> User Rights Assignment to:

  • Back Up files and directories
  • Debug programs
  • Manage auditing and security log

More on this error here: SQL Server installation fails

|improve this answer|||||
  • 1
    Thanks Gehan but I have no Access Denied error messages or anything pertaining to lack of privileges. Both accounts I have tried the install with are member of the local Administrators group which has the rights above assigned. Please let me know if you have seen anything in the logs though that makes you think differently – Chriis Aug 5 '15 at 14:47
0

Seems like it was due to the cross-site cluster configuration

The SQL Instance had 2 IP's with an OR dependency. It seems like the offline IP is causing an issue with the patch. This has been removed from the SQL Role and patching of the first node has completed successfully

Unfortunately I don't know enough about the configuration to know if this is usually a requirement prior to patching or something not 100% correct in the cluster configuration as obviously SQL Server is happy enough with using the different IPs when the instance is running from the different sites and happy with the configuration with one always being offline

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.