16

I recently had a problem while installing Visual Studio 2012 and SQL Server 2008 R2 on a new development machine. My installation sequence was Visual Studio 2012 then install SQL Server 2008 R2.

An error occurred during the middle of SQL Server installation:

The specified account already exists.

I have spent my day trying to fix this problem.

  • Did you find a solution without uninstalling SQL Native client? I have to install SQL Mng Studio on an ERP application server and I think it would be too dangerous uninstalling the db client. – Tobia Jan 23 '18 at 6:18
7

First, search the installation log. In my instance it was under the following path:

C:\Program Files\Microsoft SQL Server\100\Setup Bootstrap\Log\*.*

In that log I found the following entries:

2015-08-07 11:16:50 Slp: Sco: Attempting to open registry subkey 
2015-08-07 11:16:50 Slp: Sco: Attempting to open registry subkey SOFTWARE\Microsoft\VisualStudio\9.0
2015-08-07 11:16:50 Slp: Sco: Attempting to get registry value InstallDir
2015-08-07 11:16:50 Slp: Target package: "D:\shared\~~~~~\sqlncli.msi"
2015-08-07 11:16:51 Slp: MSI Error: 1316 The specified account already exists.

I then located the file sqlncli.msi and opened a command prompt to execute this command:

msiexec /i "d:\[Your sqlncli.msi path]

I then uninstalled the SQL Server Native Client and ran the installation for SQL Server again, success.

  • 1
    Was there any specific article or process that lead you believe you needed to remove the native client? – Shawn Melton Aug 7 '15 at 4:01
  • 4
    Just to say that this worked for me when I hit this error with SQL Management Studio 2014. I had to uninstall SQL Native Client 2012 for some reason... – x3ja Sep 24 '15 at 21:43
6

Regarding where is the indication that SQL Native Client is the issue – the error actually occurs while trying to install the newer SQL Native Client. The solution seems to be: go to Add/Remove Programs and then remove the older SQL Native Client and then retry. No need to abort the installation.

After the older SQL Native Client has been removed, the installation seems to proceed without any problem.

  • 1
    This works for me by just uninstalling the previously installed SQL Native Client. – Jerameel Resco Oct 20 '16 at 8:16
4

For completeness: This also happens when the original msi package had a different name.

If you installed myproductV1.msi and then tried to update it using

msiexec /fvomus myproductV1.msi

it works as expected. But when using

msiexec /fvomus myproductV3.msi

it fails with the mentioned error. Assuming that only the filename changes. Content (especially all GUIDS) stays the same

1

Uninstall every SQL components from programs and features (appwiz.cpl -shortcut). Then remove cash and restart the system.

This solution has fixed mine.

0

I received the same error 1603 while installing Sql server 2014. As per the instructions, I have uninstalled sql server 2012 native client but continued to receive the error. You will have to find the product name in the log file that is causing this error and uninstall that application and this error will go away. I had to uninstall MICROSOFT_VCPP2010SP1.

  • Hello and welcome to the site! It would probably be helpful if you clarified which log you are talking about. I'm presuming you mean the installation log but it's but not to leave room for such guesses. Feel free to edit your post to add useful details. Thank you. – Andriy M Sep 5 '18 at 6:25
0

A different, simpler solution was to install this tool from Microsoft: https://support.microsoft.com/en-ca/help/17588/fix-problems-that-block-programs-from-being-installed-or-removed

It's a troubleshooter that actually shoots your troubles away. At least, it worked for me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.