1

I am having a problem with one of my MySQL servers running CentOS 7. I have it almost setup with a master master replication status. But I keep getting this:

MariaDB [(none)]> show slave status\G *************************** 1. row *************************** Slave_IO_State: Connecting to master Master_Host: 192.168.220.80 Master_User: replication Master_Port: 3306 Connect_Retry: 60 Master_Log_File: mysql-bin.000037 Read_Master_Log_Pos: 245 Relay_Log_File: mariadb-relay-bin.000001 Relay_Log_Pos: 4 Relay_Master_Log_File: mysql-bin.000037 Slave_IO_Running: Connecting Slave_SQL_Running: Yes Replicate_Do_DB: Replicate_Ignore_DB: Replicate_Do_Table: Replicate_Ignore_Table: Replicate_Wild_Do_Table: Replicate_Wild_Ignore_Table: Last_Errno: 0 Last_Error: Skip_Counter: 0 Exec_Master_Log_Pos: 245 Relay_Log_Space: 245 Until_Condition: None Until_Log_File: Until_Log_Pos: 0 Master_SSL_Allowed: No Master_SSL_CA_File: Master_SSL_CA_Path: Master_SSL_Cert: Master_SSL_Cipher: Master_SSL_Key: Seconds_Behind_Master: NULL Master_SSL_Verify_Server_Cert: No Last_IO_Errno: 1045 Last_IO_Error: error connecting to master 'replication@192.168.220.80:3306' - retry-time: 60 retries: 86400 message: Access denied for user 'replication'@'asm-sql01.borg.priv' (using password: YES) Last_SQL_Errno: 0 Last_SQL_Error: Replicate_Ignore_Server_Ids: Master_Server_Id: 0 1 row in set (0.00 sec)

MariaDB [(none)]>

  • Did you read the part Access denied for user 'replication'@'asm-sql01.borg.priv' (using password: YES)? Is a permission issue. – oNare Aug 17 '15 at 20:30
  • yes. I tried granting permission to all databases. It wouldn't take. I'm guessing I did something wrong... – andrewm659 Aug 17 '15 at 21:33
  • Take a look here: mariadb.com/kb/en/mariadb/setting-up-replication. GRANT REPLICATION SLAVE ON *.* TO 'replication_user'@'slave_host' IDENTIFIED BY 'bigs3cret'; FLUSH PRIVILEGES; – oNare Aug 17 '15 at 21:38
  • I tried this from phpMyAdmin....I guess don't trust this? – andrewm659 Aug 18 '15 at 1:20
  • Do I need to stop the slave process when doing this? – andrewm659 Aug 18 '15 at 1:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.