5

I am getting this error in Windows Server 2012 with Visual Studio 2012 installed trying to open SQL Server Management Studio 2012:

Cannot find one or more components. Please reinstall the application

I tried many things, including installing SQL Server Management Studio 2014, uninstalling, reinstalling… Then repairing VS2012, installing SSMS 2014 again. All to no avail.

  • Can you take a look at the error log to identify which component failed and post it on here? – Hector Aug 18 '15 at 16:58
7

Uninstall the Visual Studio 2010 Shell, this was done by downloading the installer.

Once downloaded, run the installer and remove the VS2010 Shell component. Once done, run the SQL 2014 Management Studio installer or do a repair on your existing installation, this will itself reinstall the VS2010 Shell components.

Then it opened for me.

In Order To Repair Sql Server Management Studio Do Below Steps -

  1. Open Control Panel Then Click on Program and Features
  2. Then Find Microsoft Sql Server 2012 , Right click on it and choose uninstall
  3. Then uninstall wizard will open and Follow the wizard steps to uninstall it.
| improve this answer | |
  • 1
    Above one worked perfectly and resolved my issue, Thanks for your suggestions. – Sajid Khan Aug 18 '15 at 17:10
  • 3
    Please mark this as the accepted answer as soon as you are able. Thanks for sharing your experiences on this. For next time, please consider asking questions like this on Super User. – Paul White 9 Aug 18 '15 at 22:17
  • Thank you so much! I created an account here just to upvote this! This solution solved my problem. I used that download to uninstall the shell, then I did a "repair" on my SQL... and now I'm back up and running :) – user952342 Feb 12 '16 at 16:09
  • The link is dead now unfortunately. This one seems to work instead: microsoft.com/en-us/download/confirmation.aspx?id=1366 – Drew Noakes Nov 23 '17 at 9:47
2

In my case, this error started happening after a large number of Windows security updates were installed, and only occurred when I tried to open SSMS by using a runas command with the /noprofile switch. This had been working fine previously, but after the patching, the presence of the /noprofile switch caused this error to come up when opening SSMS 2014.

I also wasn't able to open Visual Studio 2010 using a runas /noprofile command either, which also had been working previously.

To resolve the issue, I did the following:

In a regular command prompt:

    Runas /user:xxx\yyyyy cmd

(where xxx\yyyy is the account that I am trying to run SSMS and VS as.)

In the new command prompt:

    C:
    cd\
    cd program files (x86)\Microsoft Visual Studio 10.0\Common7\IDE
    devenv /resetuserdata

After this, all my settings for Visual Studio were gone, but otherwise I was able to open both Visual Studio 2010 and SSMS 2014.

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.