2

Recently we have encountered seriously problem since we moved our mysql database from EC2 to RDS.

We do have high cpu usage before moved to rds, but our website has a good speed for our customers. After set up instance in RDS, our speed dramatically down without any reasons.

We checked our metrics on RDS, then we found that we have almost 100 write count/sec in anytime of day, even we do not have too many customers at nighttime, but the write count/sec is still remain around 100 count/sec.

And we have checked our general_log and slow_log files, but we do not where the write operations from ?

Anyone experience similar problems ?

Our configuration of rds:

Mysql 5.6.23 db.r3.large

Our metrics snapshot: enter image description here

enter image description here

Many Thanks

  • curious, did you ever find the cause of your issues? I'm looking at a similar pattern. – Stepan Mazurov Sep 23 '15 at 23:07
  • @smazurov We are still looking at this issue, because we use Drupal as backend, something we have to dig inside it. Now, we are using static page caching. – tim Oct 14 '15 at 23:13
  • @smazurov Just modify your View's setting in Drupal. Do NOT use Full Pager for any views. Try to use Mini Pager instead of it. – tim Dec 17 '15 at 4:12
  • I am not using Drupal, @tim, so unfortunately your solution isn't something that can be translated to my use case. – Stepan Mazurov Dec 21 '15 at 19:05
  • @smazurov Oh... You could use slow query to record SQL statement which slow down your speed. Then find out where is the SQL statement come from. Hope this could help you. – tim Jan 4 '16 at 3:57
0

The poor performance of this is due to the pager of view, just modify the view setting to "Mini Pager" or others except "Full". Your database performance will boost twice times as before.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.