10

First of all, excuse the length, this post is very long, and needs some background, second; it has been hard for me discerning the signal from the noise, please bear if some of this is not relevant:

Several weeks ago, I voluntarily chose to upgrade to Windows 10. After doing that, I finally decided to remove the Python installations I did not need anymore. After removing the latest 2.7 (and keeping only 3.4.3), everything seemed to work out fine, until my computer crashed unexpectedly. Since then, Windows 10 was never the same, extremely unreliable.

I was forced to downgrade to Windows 7 again, and upon startup. I received two error messages: One that said python dll was not found, and the other one that said:

The procedure entry point RpcImpersonateClientContainer could not be located in the dynamic link library RPCRT4.dll

This second error, I believe is crucial. A cursory search points to this, which says it's a Windows 10 only process.

I managed to reinstall and uninstall python 2.7 and 3.4.3 several times, and the python dll error did not appear anymore (so I currently have 3.4.3 as the only Python version in my machine).

However, the second error persisted. I tried to uninstall all of the MySQL services in my machine, and I succeded for the most part, except for two:

MySQL Connector 6.9.5 and MySQL for Excel 1.3.3 I have been unable to uninstall, no matter what I do. I tried the solution in this answer, but got the following error:

OpenService FAILED 1060:

The specified service does not exist as an installed service.

Now I am trying to reinstall MySQL community edition 5.6.26.0, via the microsoft installer (extension msi). I click on it, and get it to show the window that says something like 'gathering the relevant information...' and then, it just vanishes.

NOTE: When I try to install via the web-community. I manage to get to the following screen (do you want this program to make changes...?), and then, it vanishes again.

Both are nowhere to be found in the Windows processes.

However, after running the web-community a couple of times, MySQL Installer -Community appears as an installed program in my list to change/uninstall. If I try to change it, nothing happens, but if I try to uninstall it:

The procedure entry point RpcImpersonateClientContainer could not be located in the dynamic link library RPCRT4.dll

Again, the second error (but manages to uninstall).

Another google search later, this french thread popped. My french is sloppy at best, but the only reply seems to suggest a corrupted DLL and perhaps a fresh install?

On a perhaps unrelated note: My computer asked me to update every single time I started it. After a couple of minutes, the familiar logo would pop over the 'shut down' option. Every time I chose to install the updates, it apparently did, and configured some more stuff at start up. But every time, it happened once more.

I checked more thoroughly and it was installing KB3083186 over and over again, so I repaired .NET 4.6, disabled automatic updates, and now it seems to be fine.

The relevant details of my machine are the following:

OS: Windows 7 home premium, service pack 1.

System:

HP Pavilion dm4 Notebook PC

Processor:

Intel Core i5-3210 CPU 2.50GHz

Ram:

6 GB

My ideal result would be to avoid a fresh install (which seems like a nuclear option for me), removing all of the MySQL services, installing them correctly, and being able to use Workbench (and other MySQL related products as well).

Edit:

Installation of HeidiSQL 9.3.0.4984 and MariaDB 10.0.21 via the windows installer (msi) worked correctly and are apparently functioning without problems. However, I would still like a proper solution for my problem, particularly given the fact that my current solution might be prone to the same issue in the future.

Update 2015-10-13: Installation of MS SQL server 2014 was unsuccessful. Again the error report is the following:

DTSWizard.exe - Entry Point Not Found

The procedure entry point RpcImpersonateClientContainer could not be located in the dynamic link library RPCRT4.dll

The (current) suggestions in the answers/comments have proved to be unsuccessful.

  • Did you try to locate a newer version of the RPCRT4.dll. I have version 10.0.15063.0. It is possible you need an older version also. – cybernard Jul 8 '17 at 14:48
2

Why not create a 1-2 GB VM with VirtualBox (free), put Ubuntu Server (also free) on it and install MySQL (for free) on that?

-1

I have a similar problem, the error "The procedure entry point RpcImpersonateClientContainer could not be located in the dynamic link library RPCRT4.dll" is shown when starting some programs (for instance KeePass.exe a password store program). The only point in common with your problem is that I also upgraded from Windows 7 64bit to Windows 10 but the upgrade failed and I have been forced to downgrade back to Win 7. From that moment on the error is present. Looking on Google I found many other posts with this error happening in different cases, having in common the Win 10 to Win 7 downgrade. Restoring the RPCRT4.DLL did not help. Look at this as an example http://answers.microsoft.com/en-us/windows/forum/windows_7-update/expresstrayexe/ddb129f6-42b7-4af3-98ea-3de850f5aec5

I also found this link https://msdn.microsoft.com/en-us/library/windows/desktop/mt297489%28v=vs.85%29.aspx where Microdoft describes the function as a new Win 10 feature not present in Win 7 or Win 8 library. (It also declares the RpcImpersonateClientContainer entry point as deprecated and not supported, possibly to be removed in future ... !!!!) I am now investigating on the possibility the upgrade to Win10 installed a new version of some dll or program that the downgrade did not restore ... this Win 10 dll could of course try to call the RpcImpersonateClientContainer not knowing it is not anymore present ...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.