1

After installation of another SQL Server 2014 instance to a server where a default instance of SQL Server 2008 R2 is present, I cannot remote connect remote to the new named instance.

The default 2008 R2 instance uses TCP port 1433 set for all "IP(n)" settings.

Here is what I read / checked / tried:

Following this question: configure remote connection for multiple instances sql server 2008

I figured several settings and tried the following:

  • Server Security: Mixed
  • Server Connections Properties: Allow [checked]
  • SQL Server Browser started
  • Protocol Settings for the 2014 instance set as follows:
    • Shared Memory=Enabled,
    • Named Pipes=Disabled,
    • TCP/IP=Enabled
      • TCP IP Setting of new instance:
        • Enabled=Yes,
        • Listen All=YES,
      • TCP/IP Settings for IP(n):
        • Dynamic Ports=erased
        • TCP Port=erased
      • IPAll Setting:
        • Dynamic Ports = erased
        • Port=49172

I tried to remote connect using [IP]:49172\Instance and HostName:49172\Instance and HostName\Instance and [IP]\Instance without success.

I try to use SQL Server authentication, the user is available and is sysadmin and can connect local.

What am I missing here?

2

The solution was to restart the SQL Server Browser. Looks like my configuration was correct but has to be made before starting this service. After that I could access the 2nd Sql Server without problems, just using the name\instance.

  • "name\instance" There it is! I forgot, The first, default instance can simply be accesses by "localhost", but the second instance needed "localhost\instance" – justinm410 Jan 27 '17 at 18:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.