5

My Stack: . Windows 10 Enterprise . SQL Server 2012 Express (with SP1 bundled).

ISSUE:
. Installed SQL to test for backward compatibility.
. When I tried to Un-Install the following prompt is thrown.

enter image description here

Attempted Resolution Step:
. uninstalling individual components.
. re-installing SP1 for that edition.

None of these steps have worked. One last resort was to delete registry entries and then reattempt to delete.

Any ideas?

3
  • 3
    This is bug in SQL Server which has already been informed via This connect item see workaround mentioned. Please also check this MSDN thread
    – Shanky
    Commented Sep 2, 2015 at 10:51
  • This post is for a different version and edition, but brute force may be an approach too: sqlblog.org/2010/10/25/… Commented Sep 2, 2015 at 10:54
  • Yes it probably has to result to brute force. Once attempted i'll post an update. Thanks. Commented Sep 2, 2015 at 11:18

1 Answer 1

2

A month later, I need to test with a full version of SQL locally but remembered I had this pain in the a** to deal with.

TO RESOLVE:

  1. Change SQL compatibility mode to "Windows Vista SP1/SP2". Go to where it was installed. Path belows for x64 version. For 32x it will be in the ~\program Files (86) directory.
    C:\Program Files\Microsoft SQL Server\110\Setup Bootstrap\SQLServer2012

    enter image description here

  2. Launch CMD, run as an Administrator. Navigate to the directory above.

  3. Type command Setupup.exe /action=uninstall
  4. Follow the prompts.
  5. Find your life ~ Shaun T :)
3
  • Who is "Shaun T"?
    – Erik
    Commented Oct 29, 2015 at 17:22
  • @Erik: Perhaps some unknown DBA aspiring to become a celebrity in the SQL or SQL Server world, and iamfobbs may thus be helping them.
    – Andriy M
    Commented Oct 30, 2015 at 7:16
  • Hahaha funny. His a sports performance trainer I get training inspiration from. "Find your life" is a term he coined that sort of means get better at what you do. if you are into fitness check out "beachbody.com" and have a look at Insanity. Find your life :) Commented Oct 30, 2015 at 17:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.