3

I am running SSMS 11.0.5646.0 on a Windows 7.0 Pro desktop connected by UTP directly to same network switch as my development server (Windows 2008R2 Standard, SQL 2008R2 SE with SP3). All within the same domain and same sub-net.

I receive the same error as in this question:

An error occurred while executing batch. Error message is: Internal connection fatal error.

I can run a query successfully 3 times in a row and then have it fail 5 times in a row. No changes to code or parameters. Interesting that I often find results in the result tab even though the error is on the message tab.

Now, when I try to re-run the query (still unmodified) I receive a modal pop-up that says:

Previous execution is not yet complete. (SQLEditors)

However, sp_WhoIsActive does not show the SPID and sp_Who2 shows it as sleeping.

This seems like an internal SSMS GUI error. I have found MANY posts, questions, etc. about similar issues going back to SQL 2005. Does anyone have any idea how to troubleshoot these issues? They are clearly SSMS client side.

Additional links:

  • 1
    Have you tried running SSMS with the /log switch to see if that gives you any extra information? – Mister Magoo Sep 5 '15 at 22:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.