0

I have install oracle 11.2.0.4 with oracle asm on oracle linux 6.4 and it work correctly . After shutdown abort , i can not start database at all . can any one help me ?

SQL*Plus: Release 11.2.0.4.0 Production on Sun Sep 6 14:14:30 2015


Copyright (c) 1982, 2013, Oracle.  All rights reserved.


Enter user-name: sys as sysdba
Enter password:
Connected to an idle instance.


SQL> startup
ORA-27137: unable to allocate large pages to create a shared memory segment
Linux-x86_64 Error: 1: Operation not permitted
Additional information: 201326592
Additional information: 1
SQL>


--------------------------------------------
[grid@localhost ~]$ asmcmd
ASMCMD> startup
ORA-01081: cannot start already-running ORACLE - shut it down first
-------------------------------------------
[root@localhost ~]#  grep Huge /proc/meminfo
AnonHugePages:    100352 kB
HugePages_Total:       0
HugePages_Free:        0
HugePages_Rsvd:        0
HugePages_Surp:        0
Hugepagesize:       2048 kB
5
  • please do a ps -fe|grep pmon and show us the output
    – miracle173
    Commented Sep 6, 2015 at 10:55
  • also do echo $ORACLE_SID, $ORACLE_HOME in the environment where you opened sqlplus and asmcmd to start the database
    – miracle173
    Commented Sep 6, 2015 at 10:58
  • oracle_sid is orcl and the output of asmcmd and startup in my question
    – saeed.sh
    Commented Sep 6, 2015 at 11:01
  • I don't understand "and the output of asmcmd and startup in my question"
    – miracle173
    Commented Sep 6, 2015 at 11:12
  • please provide the output of the ps command (see one of the comments above)
    – miracle173
    Commented Sep 6, 2015 at 11:14

1 Answer 1

1
$ oerr ora 27137
27137, 00000, "unable to allocate large pages to create a shared memory segment"
// *Cause: Parameter USE_LARGE_PAGES set to only, but large pages were not
//         configured properly
// *Action: Check alert file for more information

Your output shows hugepages were not configured, but the database is configured to use only large pages (use_large_pages=only), hence it can not start.

Configure the required amount of pages by setting the vm.nr_hugepages in /etc/sysctl.conf, the appropriate memlock limit in /etc/security/limits.conf, then reboot and start the database.

Configuring HugePages on Linux

If you do not need hugepages, simply edit the parameter file of the database, and unset the use_large_pages parameter.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.