1

I am attaching a SSAS database that I have just moved to a different drive following the below link:

Attach and Detach Analysis Services Databases

First I had to grant permissions on the new drive to the ssas services account:

enter image description here

Second when I attach the database I get the following error:

TITLE: Microsoft SQL Server Management Studio

Errors in the metadata manager. The operation cannot be executed since the database folder '\?\F:\SSAS\Data\Boden BI DEV 9_02.0.db' for the database with the name of 'Boden BI DEV 9_02', ID of 'Boden BI DEV 9_02' already exists. (Microsoft.AnalysisServices)

As you can see on the picture below

enter image description here

It says the database already exist, but I have detached it from the engine, as you can see on the picture below.

enter image description here

2

I found what the problem was. I had not deleted the database from its original location, after I detached it.

I copied the database to the new drive, which on my case is T:.

After I deleted the database from its original location, in my case F:\ssas\data, then I could attach the database from T:.

After attached, I checked on the F:\ssas\data folder and SSAS had created the following structure there, see below.

enter image description here

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.