1

I have installed database 11g on machine A (Windows). Now I need to access that database from machine B (Windows), where my application is placed. I am able to ping B --> A but telnet is not working. Can someone help me on this. Some help will be really appreciated. Below are few files for reference.

Below are few things which I have already tried:

  1. Disabled firewall.
  2. Opened ports using inbound and outbound rules.
  3. Started the services.

listener.ora

# listener.ora Network Configuration File: C:\app\rajhegde\product\11.2.0\dbhome_1\network\admin\listener.ora
# Generated by Oracle configuration tools.

SID_LIST_LISTENER =
  (SID_LIST =
    (SID_DESC =
      (SID_NAME = CLRExtProc)
      (ORACLE_HOME = C:\app\rajhegde\product\11.2.0\dbhome_1)
      (PROGRAM = extproc)
      (ENVS = "EXTPROC_DLLS=ONLY:C:\app\rajhegde\product\11.2.0\dbhome_1\bin\oraclr11.dll")
    )
  )

LISTENER =
  (DESCRIPTION_LIST =
    (DESCRIPTION =
      (ADDRESS = (PROTOCOL = IPC)(KEY = EXTPROC1522))
      (ADDRESS = (PROTOCOL = TCP)(HOST = rajhegde-lap2)(PORT = 1522))
    )
  )

ADR_BASE_LISTENER = C:\app\rajhegde

tnsnames.ora

# tnsnames.ora Network Configuration File: C:\app\rajhegde\product\11.2.0\dbhome_1\network\admin\tnsnames.ora
# Generated by Oracle configuration tools.

LISTENER_ORCL =
  (ADDRESS = (PROTOCOL = TCP)(HOST = rajhegde-lap2)(PORT = 1522))


ORACLR_CONNECTION_DATA =
  (DESCRIPTION =
    (ADDRESS_LIST =
      (ADDRESS = (PROTOCOL = IPC)(KEY = EXTPROC1522))
    )
    (CONNECT_DATA =
      (SID = CLRExtProc)
      (PRESENTATION = RO)
    )
  )

ORCL =
  (DESCRIPTION =
    (ADDRESS = (PROTOCOL = TCP)(HOST = rajhegde-lap2)(PORT = 1522))
    (CONNECT_DATA =
      (SERVER = DEDICATED)
      (SERVICE_NAME = orcl)
    )
  )

Output of lsnrctl status

C:\Users\rajhegde>lsnrctl status

LSNRCTL for 64-bit Windows: Version 11.2.0.1.0 - Production on 09-SEP-2015 18:56
:36

Copyright (c) 1991, 2010, Oracle.  All rights reserved.

Connecting to (DESCRIPTION=(ADDRESS=(PROTOCOL=IPC)(KEY=EXTPROC1522)))
STATUS of the LISTENER
------------------------
Alias                     LISTENER
Version                   TNSLSNR for 64-bit Windows: Version 11.2.0.1.0 - Produ
ction
Start Date                09-SEP-2015 17:40:03
Uptime                    0 days 1 hr. 16 min. 36 sec
Trace Level               off
Security                  ON: Local OS Authentication
SNMP                      OFF
Listener Parameter File   C:\app\rajhegde\product\11.2.0\dbhome_1\network\admin\
listener.ora
Listener Log File         c:\app\rajhegde\diag\tnslsnr\RAJHEGDE-LAP2\listener\al
ert\log.xml
Listening Endpoints Summary...
  (DESCRIPTION=(ADDRESS=(PROTOCOL=ipc)(PIPENAME=\\.\pipe\EXTPROC1522ipc)))
  (DESCRIPTION=(ADDRESS=(PROTOCOL=tcp)(HOST=RAJHEGDE-LAP2.oradev.oraclecorp.com)
(PORT=1522)))
Services Summary...
Service "CLRExtProc" has 1 instance(s).
  Instance "CLRExtProc", status UNKNOWN, has 1 handler(s) for this service...
The command completed successfully
5
  • Could you be more precise on which machine you have these files and on which machine you run the commands you tried? Looks to me that it is all on the same machine. Did you install the oracle client on Machine B? – Marco Sep 9 '15 at 13:56
  • Yes it is on same machine. But I am not able to telnet from machine B to A. I have installed SQL Developer on machine B and I am trying to connect, but since telnet is not happening, connection is not getting established. – Rajesh Sep 9 '15 at 14:00
  • The listener needs to run on the Machine A. Also when the database in on Machine A then you should use that in the tnsnames.ora file. I suppose that the database is called ORCL so the HOST must be Machine A and not localhost. I do not know why you want to use telnet. Oracle does not need that to connect to a database on another server. – Marco Sep 9 '15 at 14:03
  • Are you trying to telnet to the default port (23), or the listener port (1522)? What about tnsping, if you have that on machine B? What error do you get from SQL Developer? If your database is actually up, what is its local_listener parameter set to? – Alex Poole Sep 9 '15 at 14:30
  • I am trying to telnet to listener port 1522. I am getting error message on sql developer (An error was encountered performing the requested operation:IO Error: The Network Adapter could not establish the connection Vendor code 17002). Local_Listener parameter is set to listener_orcl. – Rajesh Sep 9 '15 at 16:52
0

Your LOCAL_LISTENER parameter is set to listener_orcl, which is defined in your tnsnames.ora as being on localhost port 1522. But your listener is on RAJHEGDE-LAP2.oradev.oraclecorp.com port 1522, so the database is unable to register itself. You can change your tnsnames.ora entry to match the listener.ora definition. After the database is restarted, or you do alter system register, the lsnrctl status output will show your service name as registered as well.

But your SQL Developer connection isn't getting that far. You can't telnet to the listener port, which means either a firewall is present (which you've assured us is not the case), or you're running a virtual machine you haven't told us about (I'm suspicious about the .oradev.oraclecorp.com domain the listener is reporting), or you're connecting to the wrong IP address.

Check that RAJHEGDE-LAP2 on machine A and RAJHEGDE-LAP2.oradev.oraclecorp.com on both machine A and machine B, and whatever host name you are using for your telnet test and connection, all resolve to the same IP address. You can also use netstat on machine A to check which IP address is listening on port 1522. You may have more than one interface and the listener isn't on the one you expect - perhaps because of a mismatch between a static address in your hosts file and what's assigned by DHCP and/or in DNS, for example.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.