0

We have increased disk space on the SQL Server, and there is definitely enough space on the server, yet below error is raised:

com.softmar.fileserver.WebFileException: com.microsoft.sqlserver.jdbc.SQLServerException: Could not allocate space for object 'dbo.WebFileImage'.'pkWebFileImage' in database 'sslFileServer' because the 'PRIMARY' filegroup is full. Create disk space by deleting unneeded files, dropping objects in the filegroup, adding additional files to the filegroup, or setting autogrowth on for existing files in the filegroup.

The properties of the database shows that there is only 1.1 MB available, yet other databases on the same SQL server shows much more space available on the properties. So why is only this database not accommodating the disk size increase? Looking at the file settings it is set to unrestricted growth.

This is rather critical so will appreciate your swift response.

enter image description here

  • 2
    You freed up space on the drive, but how much space did you free up? What is the current size of the file? What is the autogrowth setting? – Aaron Bertrand Sep 15 '15 at 19:44
  • This may help you out – Zane Sep 15 '15 at 19:46
  • The autogrowth setting is: 1024 MB, unrestricted growth. There are two relevant databases on the particular SQL server. The one database is perfectly fine in terms of space, but this particular database seems to be stuck on the available space. So it's like it's not refreshing? Running sp_spaceused on the database yields the following results: database_size: 98792.5MB | unallocated space: 1.88 MB | reserved: 100113024 KB | data: 100097224 KB | index_size: 1048 KB | unused: 14752 KB – Marieke Smit Sep 15 '15 at 20:02
  • Can you post the results of this query: USE sslFileServer; GO SELECT d.name , mf.name , mf.physical_name , Size = mf.size * 8192E0 / 1048576 , MaxSize = mf.max_size * 8192E0 / 1048576 , Growth = mf.growth * 8192E0 / 1048576 FROM master.sys.databases d INNER JOIN master.sys.master_files mf ON d.database_id = mf.database_id WHERE d.name = DB_NAME() ORDER BY d.name , mf.type , mf.name; – Max Vernon Sep 15 '15 at 20:07
  • So the data file needs to grow by 1 GB. Is there more than 1 GB available on that database's disk? – Aaron Bertrand Sep 15 '15 at 22:58
-2

add a file to your database and set it's filegroup to primary.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.