The Enterprise Manager jobs on our RAC system recently started intermittently failing initialization with the following error:

Error evaluating parameter sources/security checks/locks ORA-06508: PL/SQL: could not find program unit being called

We have tried bouncing DBConsole, re-submitting the job from the library and even recompiling the package being referenced. This is happening to multiple jobs with about one execution in every ten scheduled succeeding. Any ideas on what can be tried or checked?

Update: I've opened a SR with Oracle.

  • Can't seem to find anything on the Oracle Support site. Probably not a good sign
    – Philᵀᴹ
    Commented Jan 26, 2012 at 10:03
  • Leigh I don't expect this to be correct, given its you that asked, but can you double check that the user executing the task has been explicitly granted execute privileges on the package that you reference. Commented Jan 26, 2012 at 10:55
  • @Phil I did some looking, but didn't see anything either. Thanks for checking. Commented Jan 26, 2012 at 14:29
  • Thanks for the vote of confidence. I did check permissions on one job just to be sure permissions were OK. They were fine and I really didn't expect them to not be since some executions are succeeding and because the problem is affecting multiple jobs hitting multiple packages. Most of the jobs are run by SYSTEM. Commented Jan 26, 2012 at 14:32

1 Answer 1


Oracle support has been no help. After about a week of the jobs sometimes running they stopped running completely. Every single job got an initialization error every time it ran and every time it was retried. We are in the process of re-creating the repository and migrating to dbms_scheduler jobs.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.