2

For one of our SQL server 2005 enterprise, configured with merge replication, we suddenly start seeing the below error message:

The insert failed. It conflicted with an identity range check constraint in database 'ABC', replicated table 'dbo.tblMtxyze', column 'csa'. If the identity column is automatically managed by replication, update the range as follows: for the Publisher, execute sp_adjustpublisheridentityrange; for the Subscriber, run the Distribution Agent or the Merge Agent.

I went through the complete process of rectifying as explained here, but no luck.

We have about 10 publication from this single database ABC containing the filtered tables, around 6 and all of them going through same error:

Any idea how can i proceed from here, apart from setting up merge replication from scratch?

Edit:

On exploring more we found that out of those 10 Publications, we have one Publication which act as master Publisher which needs to be working in order for rest 9 to work.

However, when we right click and went to properties of that publication, the articles( 6 common tables among all 10 pubs) were not at all present out there on this master publisher.

So we went ahead and try adding those articles , but it threw us error saying

An article with a different subscriber_upload_options value already exists for object '[dbo].tbl1

In order to resolve, we though this being master, went ahead and removed one article at a time from other 9 publications, thus allowing that table1 to show in article on master publication.

But again, the same thing goes if i try to add removed articles back to other 9 publications with same error.

What can be done here? We are out of thoughts for now as this merge replication seems very complicated!

Thanks!

  • Could you share any more information on what you saw (or did not see) when going through the complete process? – RLF Sep 23 '15 at 13:11
  • As mentioned on doc i ran SELECT IDENT_CURRENT ('<TableName>') and for all the 6 tables and as per script for result where op was 0 aded+1 for min value found and where o/p greater than 0, added+1 for high ident value found. – KASQLDBA Sep 23 '15 at 13:24
  • Although it may not be ideal, did you try sp_changemergepublication '<PublicationName>', 'max_concurrent_merge', 1 to see if merging one subscription at a time does resolve the error? And are you running at least SQL Server 2005 SP2 Cumulative Update 8? – RLF Sep 23 '15 at 13:38
  • Yes i tried, and its SP4, but no luck – KASQLDBA Sep 23 '15 at 13:58
  • Ok, i just found something. Here is this one master Publisher which manages other publishers. Now when i see its articles, there are none of those 6 tables which other publisher have. I tried adding those 6 tables in articles but get the error message "An article with a different subscriber_upload_options value already exists for object '[dbo].[Material]'." – KASQLDBA Sep 23 '15 at 14:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.