1

MS Access 2010 has a vey weird behaviour for me. Whenever I create a new Query, it silently adds a wildcard (i.e. ', *') to the end of the SELECT clause.

The wildcard is visible only in the SQL and Data views, but not in the Query Structure view.

For example, I start a new query via 'Create > Query Structure', add a table, add one column, and the SQL result is:

SELECT TABLE1.COLUMN1, *
FROM TABLE1;

What can I do to prevent that unwanted trailing wildcard?

  • Are you referring to the 'asterisk' displayed here: pasteboard.co/UgUDtMW.png ? – Nelz Sep 25 '15 at 15:52
  • Almost exactly. The one in your screenshot is in the form TABLE1.*; the one that is automatically added shows just as an asterisk. The only way to remove it is to go to the SQL view and edit it out manually every time... – lmari Sep 28 '15 at 11:10
0

You apparently have the "Output all fields" option enabled for query design. To turn it off,

  • choose "Options" from the "File" tab of the ribbon,
  • on the "Object Designers" tab, remove the checkmark beside "Output all fields" in the "Query design" section.

AccessOptions.png

  • Thank you very much, I don't know how I missed that! – lmari Oct 27 '15 at 13:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.