0

Is it possible to downgrade oracle 11.1.0.6.0 to 10.2.0.4.0? The Compatible parameter need to be changed to "10.2.0"? Today I have Compatible set to 10.2.0.4.0.

It's not clear on support.oracle if I need to change or not. This document http://www.oracle.com/technetwork/database/upgrade/upgrade11gr2-downgrade-methods-179029.pdf

state:

The major restriction on the downgrade script is that it cannot be run if the COMPATIBLE parameter has been raised as part of, or after, the upgrade. This is because raising the COMPATIBLE parameter will allow on-disk changes that cannot be understood by the earlier version of Oracle Database. For this reason, downgrades from Oracle Database 11g Release 2 to Oracle Database 9i are not supported. Downgrades from Oracle Database 11g Release 2 to the following versions are supported:  10.1.0.5  10.2.0.2, 10.2.0.3, 10.2.0.4, 10.2.0.5  11.1.0.6, 11.1.0.7

but this one http://docs.oracle.com/cd/E11882_01/server.112/e17222/downgrade.htm#UPGRD12554

says:

If you are downgrading to Oracle Database 10g Release 2 (10.2), then the COMPATIBLE initialization parameter must be set to 10.2.0 or lower.

thx

  • how about a fresh install of 10.2 (out of support for many years) and then import your data from 11g? – kevinsky Oct 1 '15 at 19:45
  • I do not have enough disk space to dump, the db is too big. And I would like to know more about the downgrade. But ty for your suggestion. – Jonathan Oct 1 '15 at 19:51
  • How do you perform backups in this case? Are talking about Petabyte? – Wernfried Domscheit Oct 1 '15 at 19:59
  • It's a lab environment. There's no backup neither dspace to dump anything. I'm just testing out. – Jonathan Oct 1 '15 at 20:03
2

Yes, it is possible, as stated in the 11.1 documentation:

Supported Releases for Downgrading

Oracle mentions 10.2.0, because ideally you need not to set anything more specific (more digits). This is explained in:

How To Change The COMPATIBLE Parameter And What Is The Significance? (Doc ID 733987.1)

Use only the first 3 digits for the compatible parameter unless there would be some very specific instructions to do otherwise. Patch sets are normally not intended to add/change actual functionality, hence there is no need to increase the compatible parameter and set the 4th digit.

If you set it to 10.2.0.4.0, the downgrade should be still successful to version 10.2.0.4, but not anything lower.

| improve this answer | |
  • Note bellow in the answer. Thx for providing me info about the downgrade. – Jonathan Oct 13 '15 at 19:09
0

The documentation is very confusing. Also, I figured out that we cannot set it to 10.2.0 (without digits) as answered by @Balazs, doing so will throw an error stating that the COMPATIBLE parameter is not correctly set. Changing it to 10.2.0.4 was possible and it was accepted by the dbase.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.