2

I need to set up a RAC environment using two nodes. Details of each server are:

OS : Windows Server 2012 R2 64bit ( certified by Oracle )

RAC: Oracle Grid 11.2.0.4

While installing the Grid Software, I am getting following error: enter image description here

I came to know from Oracle Metalink, this is bug and had been solved in patch 20502905. I tried to apply this patch using the latest opatch 11.2.0.3.12 (required 11.2.0.3.5 or later) but I am unable to apply this patch because I am getting this error:

enter image description here

Since RAC installation is not completed yet that's why database has not been installed. As I know to use opatch we need to set ORACLE_HOME to database home and need to set OPatch directory path in the PATH variable of OS. But I can not set the path of ORACLE_HOME.

Could you please suggest me how to proceed. Any help is appreciated.

1

Thanks all for your help. Here is the solution:

  1. Do standalone installation of Grid Software on each server one by one. (Don't configure Grid now.)
  2. Download the required patch.
  3. Unzip the patch in temp folder and then copy and paste it to Oracle GRID_HOME\OPatch directory. Don't delete any file, if asked click on Merge.
  4. Set the ORACLE_HOME=GRID_HOME and then after set the path of OPatch in PATH environment.
  5. Now apply the patch by following the steps provided in README file along with patch.
  6. Once it is done, Start the Grid configuration , hopefully you won't face any issue.
0

Try specifying the location of Java when running OPatch, e.g:

opatch apply –jre %ORACLE_HOME%\jdk

or

opatch apply –jre C:\app\product\11.2.0\grid\jdk

Make sure the jdk folder exists with the correct content.

If the above still does not work, set the below before starting opatch:

set ORACLE_HOME=C:\app\product\11.2.0\grid
set JAVA_HOME=C:\app\product\11.2.0\grid\jdk
set PATH=%JAVA_HOME%\bin;%ORACLE_HOME%\bin;%ORACLE_HOME%\OPatch;%PATH%

Then try running again the above.

  • I just now tried the same but getting the same error. Please let me know if any other information is needed to resolve this issue. – Prabhakar Oct 14 '15 at 11:40
  • I tried the above one just now but still getting the same error. :( – Prabhakar Oct 14 '15 at 12:05
  • Could you please tell me how to verify that JAVA HOME has all the files that need to be there to run opatch utility. – Prabhakar Oct 14 '15 at 12:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.