1

I have a package that has an Execute Sql Task. When I run it in SSDT it works fine, the query is executed. When I deploy it on the server and run the package, the query is not executed and there is no error in the execution report. Even if I put "BLABLABLA" as the query, there is no fail. The query is not dynamic.

I've started SQL Profiler while running the package and I can see that the Task goes through the Pre and Post Validation, but the query is never executed.

I've tried running the package on the server with my user with no luck.

Here's a screen shot of my package. Package

I've disable all other task to isolate the problem.

Thanks for your help

  • Do you have any configurations that might be affecting where the task might be running? – Kenneth Fisher Oct 16 '15 at 15:22
  • The connection used is parameterized, but I have other package invoked later in the process that use the same connection and they work. – tolrahC Oct 16 '15 at 15:29
  • scr_Start has a precedent constraint that is not being satisfied. You'll see that seq_Execute never shows in your SSIS execution report (assuming project deployment model) – billinkc Oct 16 '15 at 15:51
  • @billinkc You got it, I totally missed that, it's working now. Could you reply to the question, I will set it as the answer. Thank you for your help – tolrahC Oct 16 '15 at 16:12
1

Expanding my comment into an answer - scr_Start has a precedent constraint, f/x, that is not being satisfied when this executes on the server. You'll see that seq_Execute never shows in your SSIS execution report (assuming project deployment model).

Either disable the script task or ensure that whatever condition is being set is valid for your server deployment.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.