0

I'm attempting to connect to a virtualized Oracle database but I am receiving the following error:

Error connecting to database: (using class oracle.jdbc.driver.OracleDriver) Listener refused the connection with the following error:

ORA-12505, TNS:listener does not currently know of SID given in connect descriptor The Connection descriptor used by the client was: foohost:1521:foodba

Since SIDs are not usable with virtualized databases I need to provide a fully qualified URL (from what I have heard), however I'm not certain how to configure Pentaho to accomplish this.

migrated from stackoverflow.com Oct 19 '15 at 9:12

This question came from our site for professional and enthusiast programmers.

2

So the trick was to go into the Options tab in the Edit Connection dialogue and create a database parameter to define the connection string.

0

I don't know anything about pentaho or kettle, but you could try using EZCONNECT syntax for the connection descriptor: //host:1521/sid

  • Pentaho accepts the host, pid and server name as 3 separate strings and concatenates them to form the connection string. I'm looking for a way to configure Pentaho to use the alternate syntax. – Stephen Brewster Oct 18 '15 at 19:59
  • Thanks for the insight and apologies for the unsatisfactory answer. you may need to change the relevant sqlnet.ora file on your client to allow you to do this, e.g.: NAMES.DIRECTORY_PATH=(ezconnect, tnsnames) – dipdapdop Oct 19 '15 at 8:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy