0

We are running SQL Server 2008 R2 on a Windows Server 2008 R2 two-node cluster.

My choice of machine is primary, and the secondary is just a low-end machine for contingency planing.

We had a failover the last day during night time and when I came to the office the next morning, I noticed that SQL Server service did not failback to the primary machine although it came back online.

All settings seems to be in place:

  1. Attachment 1 shows the general tab of SQL Server service properties dialog box from Server Manager - > Failover Cluster Manager. Both machines are checked, primary being at the top.

    enter image description here

  2. Attachment 2 shows failover tab of the same dialog box. Immediate failback is activated.

    enter image description here

How can I modify these settings so that whenever the primary comes back, system will failback onto it.

  • I think it's because you have both nodes as the preferred owners. That means it won't favor one over the other. Try un-ticking the secondary node. – dwjv Oct 19 '15 at 10:23
  • I suspected that as the culprit too but did not want to go ahead and untick without being 100% sure about the consequences because it is prod environment and I have no option to test it first. Any input about the complications of leaving the checkbox of the second node unchecked is appreciated. – Stackoverflowuser Oct 19 '15 at 13:48
  • 1
    I'm afraid I can't say for certain as this isn't really my area. I can certainly say though, that in my situation I only have one node as the preferred node but I don't have automatic failback enabled. Normal failover works as you'd expect (2012 R2 though). – dwjv Oct 20 '15 at 9:39
1

I set up a virtual lab environment simulating a clustered network where I unticked one of the nodes as the preferred owner. I can confirm that whenever the ticked node goes offline, the unticked one comes into play and the system failbacks onto the ticked node once it comes online again.

  • 1
    Bingo! Thanks for doing the leg-work on this one. – dwjv Oct 23 '15 at 11:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.