0

This question already has an answer here:

root.sh script execution failing with following error please advice

./root.sh
Performing root user operation for Oracle 12c

The following environment variables are set as:
    ORACLE_OWNER= grid
    ORACLE_HOME=  /u01/app/grid/product/12.1.0/grid

Enter the full pathname of the local bin directory: [/usr/local/bin]:
The contents of "dbhome" have not changed. No need to overwrite.
The contents of "oraenv" have not changed. No need to overwrite.
The contents of "coraenv" have not changed. No need to overwrite.


Creating /etc/oratab file...
Entries will be added to the /etc/oratab file as needed by
Database Configuration Assistant when a database is created
Finished running generic part of root script.
Now product-specific root actions will be performed.
Using configuration parameter file: /u01/app/grid/product/12.1.0/grid/crs/install/crsconfig_params
LOCAL ADD MODE
Creating OCR keys for user 'grid', privgrp 'oinstall'..
Operation successful.
LOCAL ONLY MODE
Successfully accumulated necessary OCR keys.
Creating OCR keys for user 'root', privgrp 'root'..
Operation successful.
CRS-4664: Node lrma086 successfully pinned.
2015/10/22 01:39:44 CLSRSC-330: Adding Clusterware entries to file '/etc/inittab'

2015/10/22 01:41:50 CLSRSC-214: Failed to start 'ohasd'

Failed to start the Clusterware. Last 20 lines of the alert log follow:
2015-10-22 01:39:34.970:
[client(21726)]CRS-2101:The OLR was formatted using version 4.
2015-10-22 01:39:39.368:
[client(21753)]CRS-1001:The OCR was formatted using version 4.

2015/10/22 01:41:50 CLSRSC-318: Failed to start Oracle ohasd service

Died at /u01/app/grid/product/12.1.0/grid/crs/install/crsinstall.pm line 2985.
The command '/u01/app/grid/product/12.1.0/grid/perl/bin/perl -I/u01/app/grid/product/12.1.0/grid/perl/lib -I/u01/app/grid/product/12.1.0/grid/crs/install /u01/app/grid/product/12.1.0/grid/crs/install/roothas.pl ' execution failed

marked as duplicate by Philᵀᴹ, RolandoMySQLDBA, Max Vernon, Kin Shah, Vérace Oct 26 '15 at 6:29

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

0

Add following: cat /etc/systemd/system/ohasd.service

[Unit]

Description=ohasd daemon

[Service]

ExecStart=/etc/init.d/init.ohasd run >/dev/null 2>&1

Reload the deamon: systemctl daemon-reload

Enable the ohasd: systemctl enable ohasd.service systemctl start ohasd.service

Check if it is running: ps -ef|grep ohas

Run the root.sh script again

  • Thanks, I got the error [root@lrma086 grid]# systemctl enable ohasd.service The unit files have no [Install] section. They are not meant to be enabled using systemctl. Possible reasons for having this kind of units are: 1) A unit may be statically enabled by being symlinked from another unit's .wants/ or .requires/ directory. 2) A unit's purpose may be to act as a helper for some other unit which has a requirement dependency on it. 3) A unit may be started when needed via activation (socket, path, timer, D-Bus, udev, scripted systemctl call, ...). – malatesh Oct 22 '15 at 7:39

Not the answer you're looking for? Browse other questions tagged or ask your own question.