0

I have run this to enable local infile:

SHOW GLOBAL VARIABLES LIKE 'local_infile';
SET GLOBAL local_infile = 'ON';
SHOW GLOBAL VARIABLES LIKE 'local_infile';

And indeed after that the local infile in on, but when I try loading file again, I still get notification, saying that my file does not exist.

Can someone tell me what should be done ?

1
  • Can you add your command and the error? – oNare Oct 31 '15 at 15:20
0

If you already enabled LOAD DATA INFILE and verified its SET to ON, most likely the command you are using or the path you specify for the text file might be wrong.

The command would be mysql> LOAD DATA LOCAL INFILE '/path/filename.txt' INTO TABLE tablename;

Refer to Load Data Infile.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.