3

This question already has an answer here:

Our organization is trying out Windows 10 and our distribution had some modifications to the ciphers in use due to recent security concerns.

As it stands SQL Server 2014 Developer SP1 fails to install properly. The services fail to start. I have tried enabling TLS 1.0 trough TLS 1.2, this led to me being able to start the SQL Engine using Local Service Account. But not SQL Agent or Browser. Nor could i connect to the server locally with SMSS all logins fail (sa or the current windows user).

Disabled SSL/TLS:
SSL 3.0 / TLS 1.0 / TLS 1.1
Enabled TLS:
TLS 1.2

Disabled Ciphers:
DES 56/56
NULL
RC2 128/128
RC2 40/128
RC2 56/128
RC4 40/128
RC4 56/128
RC4 64/128
RC4 128/128
Enabled Ciphers:
AES 128/128
AES 256/256
Triple DES 168/168

Hashes:
MD5 (Disabled)
SHA (Enabled)
Diffie-Hellman (Enabled)
PKCS (Enabled)

Ciphers are then sorted from most secure to least secure.

Setup Bootstrap Log:

  Feature:              Database Engine Services
  Status:               Failed: see logs for details
  Reason for failure:   An error occurred during the setup process of the feature.
  Next Step:            Use the following information to resolve the error, uninstall this feature, and then run the setup process again.
  Component name:       SQL Server Database Engine Services Instance Features
  Component error code: 0x851A0019
  Error description:    Could not find the Database Engine startup handle.

ERRORLOG when trying to start SQL Server Engine during setup:

Error: 17190, Severity: 16, State: 1.  
Initializing the FallBack certificate failed with error code: 1, state: 20, error number: 0.  
Unable to initialize SSL encryption because a valid certificate could not be found, and it is not possible to create a self-signed certificate.  
Error: 17182, Severity: 16, State: 1.  
TDSSNIClient initialization failed with error 0x80092004, status code 0x80. Reason: Unable to initialize SSL support. Cannot find object or property.  
Error: 17826, Severity: 18, State: 3.
Could not start the network library because of an internal error in the network library. To determine the cause, review the errors immediately preceding this one in the error log.  
Error: 17120, Severity: 16, State: 1.  
SQL Server could not spawn FRunCommunicationsManager thread. Check the SQL Server error log and the Windows event logs for information about possible related problems.

My next course of action is to try to enable the most likely culprits like SSL 3.0 and then move on to enabling ciphers.

But if anyone can shed some light as to the requirements of SQL Server 2014 SP1 or if i am looking in the wrong place, please let me know.

marked as duplicate by Paul White says GoFundMonica Mar 20 '16 at 4:30

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

2

After re-enabling all the ciphers and SSL 3.0 I completely uninstalled the broken installation.

I logged out and used a second administrator account to wipe the User Profile who installed the SQL Server. I removed any fragments of SQL Server Installation in the registry that i could find.

Also i deleted any user profile created by SQL Server and removed them from the registry.

After this the Installation worked, almost anyways, the default Service account for SSAS failed to start the AS Service but switching to another service account worked.

Still not sure if it was a corrupted User Profiler or the fact that SSL 3.0 and Ciphers were disabled. It could have been a combination.

Not the answer you're looking for? Browse other questions tagged or ask your own question.