0

I have a "Microsoft SQL Server Express 2008 R2 SP1" installation on a machine without the "Advanced Services". Now I want to install the "Full-text Search", so I downloaded the setup "SQLEXPRADV_x64_DEU.exe".

The problem is, if I start the setup, select my existing sql-instance and go further to the feature-selection menu, I don't see the "Advanced Services". I just see the already installed features. Here's a screenshot (in german): enter image description here

I did the installation of the "Full-text Search" on about 20 different machines with existing sql-instances without problems. But on this machine, I don't know what's the problem.

Hope somebody can help me! Thanks in advance!

  • It is not unknown for SQL Server installations to have problems. It is likely that the installation 'believes' Full-Text Search is installed and so it does not try to install it again. Recommend backing up your databases and then completely uninstall SQL Server from the server. Delete any SQL Server media from folders, etc. Then reinstall and restore your databases. – RLF Nov 19 '15 at 14:29
  • I didn't uninstall our existing instance yet, but I tried to setup a new one. Here I have the same problem. I still can't select "Advanced-Features" like "Fulltext-Search" because they are not visible. Do you still think, this behavior can change, if I uninstall the existing instance? – roli09 Nov 19 '15 at 14:52
  • I do not understand everything that can go wrong with a SQL Server installation. But back in the SQL Server 2005 period, it was a common problem and I have used the fix on more recent versions such as SQL Server 2008 R2 as well. Look at: blogs.msdn.com/b/astebner/archive/2005/09/13/465401.aspx, blogs.msdn.com/b/astebner/archive/2005/12/08/501885.aspx The poster said he: 1. Delete all relevant register keys, 2. Delete the C:\Program Files... folder for SQL Server, 3. Download msizap and axe the relevant product codes. (I personally never had to use msizap.) – RLF Nov 19 '15 at 15:08
  • I'll try to set up a new sql server 2012 sp2 express edition instance with fulltext-search. If that works, I'll transfer my databases and uninstall our existing 2008 R2 instance. Because there are running some other 2008 R2 instances (SBSMonitoring, Reporting), I can't easily uninstall everything like you suggested. Nevertheless thanks for your nice help! – roli09 Nov 19 '15 at 15:39
1

For all people which have the same problem, I solved it this way:

I installed a completely new "SQL Server 2012 SP2" instance (with fulltext-search), transferred my databases to the new instance and uninstalled the old one.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.