A simple question,

We have just done a P2V and are re-testing the environment and moved from SQL 2005 to SQL 2008R2. I am taking this chance to redo my back up plans. I have set up a remote folder on the domain and am having trouble accessing it. I have permissions on the folder of SERVICE plus AD administrators, and my SQL instance is running the Local Network service built in account.

This is not working I am trying to follow the question Here but not sure how to use this proxy in a maintenance plan / sql job. I am trying to avoid setting my SQL service accounts to administrator. Can this be done?

  • If you have already defined SQL proxy, you need to edit the SQL job and change the runas account in SQL job step to proxy account. I am assuming that your proxy account has all the necessary permissions on backup share.
    Nov 25, 2015 at 10:22

1 Answer 1


You may proceed with something like creating a proxy account and then assigning the same to SQL Agent job:

  • Assuming you have Maintenance plan created, which will have its corresponding job created out there on Job activity. Create a SQL login which later you need to give the required roles to execute the SQL agent jobs and assign this login as job owner of the Main'ce plan job

  • Before you create a proxy account you will need to create a credential as explained in How to: Create a Credential

  • Now for the SQL login created earlier assign the roles out of below as per you're security standards:

    1. SQLAgentOperatorRole

    2. SQLAgentReaderRole

    3. SQLAgentUserRole

  • Once login has been created with sufficient roles as above you can create proxy account as explained How to: Create a Proxy. In the ‘Principals’ option, select the SQL login which was created in above step.

  • Now the final step would be to run this proxy account in the job step properties of the maintenance plan. You can select the proxy created from dropdown under the section which says "Run As".

  • Finally test the proxy by executing the job.

  • I have been working on this a while now. My new login can not "see" Maintenance Plans, when I connect to the instance I want to run the back up on, also when I use this user to review the proxy I create with the admin account I can not select a credential correctly. I have purposely kept my login out of the sysadmin server role so I could map the proxy to the credential in SQL Agent. What have I got wrong, the only server role on my SQL_RemoteBackup login is Public
    – Ian W
    Dec 1, 2015 at 14:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.