0

I have tried almost every solution on the internet however I still cannot fix this problem. I cannot login as sysdba every time I try SQL>connect /as sysdba I get the error ERROR:ORA-01031: insufficient privileges.

My account is in ora_dba group. I'm using oracle 10g. I'm new to database so I really don't know what to do.

1

I assume that you run this on the server that hosts the database and that you have set the ORACLE_SID to the one of the database that you want to access. You must run the orapwd application. This generates a file that holds the password. Check the documentation for the exact syntax. It depends a bit on the OS on which you host the database.

| improve this answer | |
  • I think I know what the problem is it might be a permission problem because when I try to login to sqlplus gui It disappears after I hit enter. I can only use it if I run it as administrator. I'm using windows 10 btw. Do you think the two problems are related? I was also able to login as sysdba and use the sqlplus gui a while ago but now I'm suddenly facing this problem. – Sarah_b Nov 26 '15 at 4:27
  • I do not know Windows 10 and I have no experience with hosting Oracle on Windows. It might be that the user with the 'problem' does not have permission to read the $ORACLE_HOME//dbs directory. To logon the way you do you need to have access to the orapwSID file. – Marco Nov 26 '15 at 7:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.