2

I am setting up a lab for testing automatic failover for SQL Server

I have a 2 node WSFC (SQL-CLUSTER-TEST-01) with the nodes

  • SQL-TEST-01
  • SQL-TEST-02

A listener SQL-HA-GRP-01

My initial testing is to just power off either of the nodes (virtual machines). It it failing correctly in one direction - SQL-TEST-01 to SQL-TEST-02. But when SQL-TEST-02 is the primary and I pull the power on it, the availability group goes into a permanent "resolving" state which I can only resolve by powering on SQL-TEST-02.

When I check the logs or try to view the properties of the availability group it says the quorum was lost.

What am I missing?

  • What quorum mode is configured for the WSFC? – Shawn Melton Dec 30 '15 at 23:08
1

Were you able to get this sorted out?

If not , try the following:

  • Go to the Failover Cluster Manager ( cluadmin.msc from Run).
  • Expand the Cluster name ( Expand meaning click on the + sign ).
  • Expand Services and Applications. You should now see your Availability Group listed there.
  • R-click on that and go to Properties.
  • In the General Tab you should see Preferred Owners.

Since you've mentioned this to be a lab environment, play around with the options ( by selecting both or alternating selection of preferred owners ) and see where that gets you. Also the tab next to General would specify if you need it to fail back. Post back with results.

  • Also confirm your quorum voting is set up correctly. – Henrico Bekker May 9 '17 at 16:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.