1

I installed and configured pgbouncer 1.5.4 on Ubuntu 14.04 LTS and I have a hard time interpreting log messages.

Basically, I have seen many errors:

2015-12-10 18:09:16.835 30488 ERROR varcache_apply failed: ERROR: invalid value for parameter "TimeZone": "localtime"

I have googled and some articles told me the root cause is coming from timezone or encoding and date style.

I tried to implement this on pgbouncer.ini:

db-order= host=xxx.xxx.xxx.xxx port=4326 user=xxxx password=xxxx timezone='Asia/Jakarta' datestyle=ISO client_encoding=UNICODE

I then tried to reload the config but still no luck and I am still seeing the same error.

Is the config need to be restarted rather than reloading?

1

Timezone is a startup variable, you need to restart the pgbouncer service. pgbouncer.github.io/config.html

Wiki answer originally a comment by 3manuek

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.