4

I have problem with installing Oracle 10.2.0.4 on Windows Server 2012 R2.

We are running old 10.2.0.4 instance on Windows Server 2008 R2. Now I have to migrate it to the Windows Server 2012 R2. Because the application using the db is old and without support, it is very risky to migrate the db to 11g or 12c. I know that 10.2.0.4 is no longer supported and 2012 R2 is not certified for 10.2.0.4.

I have tried the following steps:

  1. To run the installer I have edited the [Certified Versions] in oraparam.ini: Windows=5.0,5.1,5.2,6.0,6.1,6.2 (I have also edited refhost.xml the same way)

  2. Then I have run the installer with "run as administrator" (I am logged as domain admin on the server) and I have installed "software only"

  3. Then I have generated the create scripts using dbca and created the instance:

    a) mkdir adump, dpdump etc.

    b) c:\oracle10\product\10.2.0\db_1\bin\oradim.exe -new -sid test10 -startmode manual

    c) c:\oracle10\product\10.2.0\db_1\bin\oradim.exe -edit -sid test10 -startmode auto -srvcstart system

    d) c:\oracle10\product\10.2.0\db_1\bin\orapwd.exe file=c:\oracle10\product\10.2.0\db_1\database\PWDtest10.ora password=test10 force=y

    e)I have copied the pfile to the c:\oracle10\product\10.2.0\db_1\database

  4. now I want to connect to the idle instance to run startup nomount:

Edit:

I am trying to connect this way under windows command prompt:

set oracle_home

set oracle_sid

sqlplus / as sysdba

But I get following error:

ORA-12546: TNS:permission denied

Then I have edited sqlnet.ora and changed sqlnet.authentication_services = (nts) to (none) and tried to logon using password file - no success.

The ORACLE_SID variable is set correctly.

  • 1
    I did not solve the problem with 10.2.0.4. But Oracle 10.2.0.5 works without any problem. – teo Jan 9 '16 at 13:50
  • Have you added the ora_dba group and added the local logged in user to it? – REW Feb 18 '16 at 18:00
  • Yes, ora_dba group is configured. – teo Mar 17 '16 at 5:18
  • Have you started both the listener and the oracle instance services? – REW Mar 17 '16 at 15:20
  • Yes, the listener and the oracle instance services are running. – teo Mar 30 '16 at 15:44
2

With no success with installing Oracle 10.2.0.4, we've tried 10.2.0.5. The installation worked without any problem.

| improve this answer | |
0

Add port listener 1521 in firewall: Inbound Rules and Outbound Rules.

Add permissions in ORACLE_HOME in regedit:

cmd → regedit → HKEY_LOCAL_MACHINE → SOFTWARE → ORACLE
| improve this answer | |
  • I think that it has nothing to do with firewall - I am connecting locally. Which permissions do you mean? – teo Jun 9 '16 at 3:44
0

The listener is attempting to spawn a server process in response to your user process' request. What's failing is the spawning of that server process using the default interprocess communication protocol (IPC). You may have better luck explicitly connecting via TCP by specifying a TNS name when calling sqlplus. You'll have to set up tnsnames.ora for the client program (on the server machine) to be able to find the listener for this to work.

| improve this answer | |
0

As there is no specific reason I would install Oracle 10 on Windows Server 2008 R2.

Else I would install Oracle 11 on Windows Server 2012 R2.

Are there any known software issues that prevent you from using Oracle 11?

You should check compatibility mode: https://docs.oracle.com/cd/E11882_01/server.112/e23633/intro.htm#CEGJDHGI

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.