My slave is not connecting to the master and is showing the error

Got fatal error 1236 from master when reading data from binary log: 'Slave can not handle replication events with the checksum that master is configured to log; the first event 'mysql-bin.000002' a'

I have tried set global binlog_checksum='NONE'; and it works fine in masters but when I try to change slaves's cnf file binlog_checksum=none it fails and MySQL won't start after restarting it.

What can I do to resolve this?

1 Answer 1


Is your slave of older version than master? Say 5.5 or less. As you say set global binlog_checksum='NONE'; fails on slave => you're on older slave and that is not required on slave as well.

  • yes my slave version is quite old 5.1 something where as master is 5.6.if it is not required then why isn't my slave working? It is still showing error I mentioned above.
    – MIC
    Commented Dec 18, 2015 at 11:11
  • 1
    Importantly consider that -->> MySQL supports replication from one release series to the next higher release series. (dev.mysql.com/doc/refman/5.7/en/replication-compatibility.html) Now, Change binlog_checksum to NONE on master and issue CHNGE MASTER TO on slave again.
    – mysql_user
    Commented Dec 18, 2015 at 11:15
  • I did nothing happened!
    – MIC
    Commented Dec 18, 2015 at 11:18
  • The events which are already logged in binlog won't be changing... you can issue flush logs and try with the next binlog instead... Again... as noted earlier this is not compatible setup....
    – mysql_user
    Commented Dec 18, 2015 at 11:43
  • doing CHANGE MASTER TO on slave again worked the second time :)
    – MIC
    Commented Dec 20, 2015 at 8:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.