0

When I try to run the command :

"C:\Program Files (x86)\MySQL\MySQL Server 5.6\bin\mysqldump.exe" -u root -p******* my_database > backups/my_database_backup_20151221121320.sql

it says

mysqldump: unknown option '--no-beep'

(I'm on windows.)

What I have tried ?

  • I read and tried many results in google (and here) about moving the "no-beep" away from the [client] section in my.ini . Did not help. still the same error.

  • I tried to check if the my.ini file that I change, is the file that actually loaded - and it is, I can change other settings and they are applied.

  • I tried running the command without the full path (Only mysqldump -u..), still the same error.

  • I searched for all the instances of "beep" in the my.ini file

  • also, when I type mysql --help it always shows no-beep = TRUE , no matter if I comment or uncomment the "no-beep"

EDIT :

using --no-defaults I have no problem, but I don't want to change the command.

Some days ago my php script worked fine, I don't know what happened.

1
  • mysqldump.exe seems the culpriti..search the mysqldump.exe in workbench installed directory usually reside parallel in program(x86) folder and try. Hope it helps Dec 21, 2015 at 10:52

1 Answer 1

1

Find all my.ini file Replace no-beep from everywhere (not only client) 'coz there is no such option. But to do a temporary fix you can use no-defaults as follows:

"C:\Program Files (x86)\MySQL\MySQL Server 5.6\bin\mysqldump.exe" --no-defaults -u root -p******* my_database > backups/my_database_backup_20151221121320.sql
2
  • Thank you, of course I tried searching for all instances. And I know that use of "no-defaults" but I am searching for a permament solution.
    – Mor Cohen
    Dec 21, 2015 at 10:55
  • The solution here is to find out what / how the no-beep is getting to mysqldump command! I thought this -> bugs.mysql.com/bug.php?id=68956 bug report has same complain but no solution except it says to remove from my.ini. There is a line in the bug report which says something about mysql workbench... Can you also go in the mysqldump.exe file's properties and verify that no-beep is not coming from there!
    – mysql_user
    Dec 21, 2015 at 11:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.