3

See this question for details of troubleshooting I've been stepping through (I did answer 2, which didn't work - it was a corrupt master file).

In configuration manager, I changed to a Built-in account, to solve the problem in the above linked question. That didn't work. When I realized it was a corrupt master file and replaced everything, the issue of starting SQL Server worked. Now I can't log into it. Originally, SQL Server Express has a default account that I've never touched in the radio option This account: and underneath that Account Name: (it appears to be NT SERVICE\MSSQL$SQLEXPRESS). Ignorantly, I've never set a password because I use Windows Authentication when logging in and from what I knew, the password was my normal Windows account. In addition, I've tried setting up a backup account as a sysadmin SQL authentication login, but it never works on logging in and after hours of research a while ago, I gave up on this (different issue, but never identified why setting up another use for sysadmin didn't work).

I've tried using the below:

NT SERVICE\MSSQLSERVER

I've also tried the options in the Built-in account Network Service, Local System, and Local Service and none of these recognize my built in Windows credentials, which is very scary (my other SQLExpress does). This doesn't work with my normal Windows password and I know the default account had $ characters in it, so I don't think that was the default. When setting up SQL Server, what default account does it use?

Update

It appears to be this account => NT SERVICE\MSSQL$SQLEXPRESS. However, my windows authentication still fails. This would imply that SQL Server set a default password for the above account when I installed, yet somehow my normal Windows Authentication username and password was able to login. I have no idea how that happened, but this appears to be the case as the Windows Auth password for the above account won't allow me to login when I log in with Windows Auth.

  • I installed it logged in as myself and the service is running under my account. Not sure if this was something I specified in the install but this goes to show, it could be anything. I would look at your services to know for sure. – Steve Dec 21 '15 at 23:48
  • @Steve Verifying => services.msc? I see the logon and hashed password for the NT SERVICE\MSSQL$SQLEXPRESS, but the problem is that the password may not be accurate if it's not using my normal Windows authentication. It will allow me to enter any password I want for that account, I just will get an error when logging in. One thing I know, it's not using my Windows password, but I wonder how the default got set to something else? – user541852587 Dec 21 '15 at 23:53
  • Is your SQL instance set to SQL Server and Windows Authentication under Properties, Security? – DoubleVu Dec 22 '15 at 13:39
  • I know this is a bit old but when services are running as NT Service\<accountname> this is the per-service SID and the OS manages the password itself. More information can be found here: https://msdn.microsoft.com/en-us/library/ms143504.aspx#New_Accounts. However, this doesn't solve the problem and I assume for this issue the original poster created their login as a sysadmin during installation. – Antoine Hernandez Feb 17 '16 at 21:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.