0

I configured master slave replication and it worked fine however it stops working after 5 min or so! Although slave status show that replication is fine, however whatever I insert in master isn't replicating in slave

enter image description here

This is the tutorial I followed http://www.tecmint.com/how-to-setup-mysql-master-slave-replication-in-rhel-centos-fedora/

Things only start replicating again when I run the command service mysqld restart on slave

master my.cnf enter image description here

slave my.cnf enter image description here

P.S I HAVE JUST ADDED "bind-address" in both of these cnf to check if it works

  • As you have replicate_do_db set the only thing will get replicated will be from those database only. Share your my.cnf. Make sure it is replicate_do_db=db0,db2,db3 and not replicate_do_db='db0,db2,db3'. – mysql_user Dec 23 '15 at 7:17
  • that's the problem. Replications work fine in these db's but after a while they stop replicating (these 3 db's). I'm sharing mycnf files above – MIC Dec 23 '15 at 7:22
  • bind-address wont be helpful. Yeah my bad about comma separated dbs in repl-filters. make sure serverids are different on client and slave. dont quote mysql (ignore-db). hen you say stop replicating do you mean data doesnt replicate or replication stops (IO/SQL thread=NO). – mysql_user Dec 23 '15 at 7:41
  • data doesn't replicate! replication is still working fine (IO/SQL thread = yes) – MIC Dec 23 '15 at 7:45
  • can you explain these "serverids" you are talking about? – MIC Dec 23 '15 at 7:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.