1

I hope you can help me.

I need to restore an Oracle 9i (9.2.0.6.0) database on a Windows Server 2003 R2 x64 from a cold backup. I managed to get the 9i installer and the version patch (since I was told I need the exact Oracle version to restore cold backups).

I installed 9i and the patch, but the Database Configuration Assistant throws an "ORA-12546:TNS Permission denied" error when creating the database (In the first step "Creating and starting Oracle instance").

Windows firewall is disabled, and my user (Administrator) is in the ORA_DBA group.

I'm new to Oracle, therefore I don't know which steps should I follow in order to solve this, and I haven't been able to find any solution on the web (maybe because 9i support ended long time away). I'm assuming if I can't even create a database, I won't be able to restore the cold backup either. Please help

Thanks in advance

  • The last answer here community.oracle.com/thread/1118217 may still be relevant. Might be an idea to create another admin user, rather than using Administrator – Philᵀᴹ Jan 14 '16 at 7:11
  • Are you installing oracle 32bit or Oracle 64 bit on windows 2003 r2 x64? – Giova Jan 14 '16 at 8:41
  • @Phil I just tried with another admin user, but I get the same error – Daniel Martinez Jan 14 '16 at 15:05
  • @Giova I assume it's 64 bit but I'm not sure where can I find that – Daniel Martinez Jan 14 '16 at 15:19
0

Please, verify if you are installing Oracle 32bit or 64 bit. This is important because Oracle in Metalink Knolwedge Base says:

Getting ORA-12546 ORA-12560 and ORA-516 while creating the database (Windows64) (Doc ID 365852.1)

You can run Oracle 32bit, on Windows 32bit. OR You can run Oracle 64bit, on Windows 64bit.

You can not mix the versions.

Also, report the complete error stack. Normally Oracle zip files have 32 or 64 bit eported in the name of the archive itself. Here you can find a lot of way to identify the executables architecture in Windows: How to check if a binary is 32 or 64 bit on Windows?

Regards

Giova

  • Awesome, thank you very much! I noticed I was using 32bit Oracle, I installed it on a 32 bit Windows server 32and it worked. Thanks!! – Daniel Martinez Jan 14 '16 at 16:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.