3

I'm trying to install SQL Server 2012 Express Service Pack 2 through command line:

SQLEXPR_x86_ENU.exe /ACTION=Install /HIDECONSOLE  /FEATURES=SQL /INSTANCENAME=SQLEXPRESS /SECURITYMODE=SQL /SAPWD="SOMEPWD" /SQLSVCACCOUNT="NT AUTHORITY\SYSTEM" /SQLSYSADMINACCOUNTS="Builtin\Administrators" /AGTSVCACCOUNT="NT AUTHORITY\Network Service"  

However I get this error message:

The syntax of argument "/HIDECONSOLE" is incorrect;Either the delimiter '=' is missing or there is one or more space characters before the '='" Error 0x84B40001

I removed the entire /HIDECONSOLE argument in my command, but I still get the same error.

migrated from stackoverflow.com Jan 25 '16 at 0:45

This question came from our site for professional and enthusiast programmers.

1

@Nissanna, As you said, you are getting the error during cmd installation of sql server express 2012.

The syntax of argument "/HIDECONSOLE" is incorrect;Either the delimiter '=' is missing or there is one or more space characters before the '='" Error 0x84B40001

when you are running this syntax:

SQLEXPR_x86_ENU.exe /ACTION=Install /HIDECONSOLE /FEATURES=SQL /INSTANCENAME=SQLEXPRESS /SECURITYMODE=SQL /SAPWD="SOMEPWD" /SQLSVCACCOUNT="NT AUTHORITY\SYSTEM" /SQLSYSADMINACCOUNTS="Builtin\Administrators" /AGTSVCACCOUNT="NT AUTHORITY\Network Service"

I would like to say that definitely you are doing some arguments mistake or permission. As MSDN BOL https://msdn.microsoft.com/en-us/library/ms144259(v=sql.110).aspx the simple syntax of installation would be as mention below format:

Setup.exe /q /ACTION=Install /FEATURES=SQL /INSTANCENAME=MSSQLSERVER /SQLSVCACCOUNT="" /SQLSVCPASSWORD="" /SQLSYSADMINACCOUNTS="" /AGTSVCACCOUNT="NT AUTHORITY\Network Service" /IACCEPTSQLSERVERLICENSETERMS

NB: For local installations, you must run Setup as an administrator.

AS local installations, you must run Setup as an administrator. If you install SQL Server from a remote share, you must use a domain account that has read and execute permissions on the remote share. For failover cluster installations, you must be a local administrator with permissions to login as a service, and to act as part of the operating system on all failover cluster nodes.

As your refence https://social.msdn.microsoft.com/forums/sqlserver/en-US/87bb5999-1126-4809-a353-0f5b06c9f81d/sql-express-2008-command-line-options and https://msdn.microsoft.com/en-us/library/ms144259(v=sql.110).aspx

0

The above error is caused because there are two or more space characters before parameters. Remove the extra spaces after '/HIDECONSOLE'

Also,check and remove if any other extra spaces remaining.

Hope it works.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy