I have SQL Server 2008 R2. I installed SQL Server 2014 with the option:

Upgrade from SQL Server 2005, SQL Server 2008, SQL Server 2008 R2 or SQL Server 2012

and the process ended correctly.

But when running on localhost:

SELECT @@Version 

I still have:

Microsoft SQL Server 2008 R2 (SP2) - 10.50.4042.0 (X64)

Sorry if the question is basic but I am very lost at the moment.


2 Answers 2


I found the problem: The installer I had was just for SQL Server Management Studio, as @MarkSinkinson pointed out.

If you have this same problem, verify you have the correct installation file (not SSMS only, or an incompatible Edition).

Other helpful things to check, from comments originally left on the question:

  • You may have multiple instances installed, upgraded one of them, and connected to another. Or the upgrade didn't take (this can be easy to dismiss without noticing in the final step of the upgrade wizard). Please note that 2008 and 2008 R2 are completely separate, independent releases.
  • Make sure that you are connected to right instance in any case.
  • Check you didn't uncheck the database engine installation option

You didn't select any instance when upgrading, just repeat the process and in step "select instance" choose the one you want to upgrade. Hope it helps

  • The OP has self-answered with a different reason for the problem. Other suggestions in their answer seem to cover what you are suggesting here, so this doesn't really add a new value.
    – Andriy M
    Nov 25, 2016 at 18:06
  • "The OP has self-answered with a different reason for the problem." that's the point, the problem was when he didn't select the instance, in fact my answer goes directly to the point, i can verify that you don't even know what i am talking about. By the way, there's no need to upgrade the SSMS to make it work. Feb 12, 2019 at 18:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.