0

I have just upgraded MySQL 5.6 to 5.7 and workbench from 6.2 to 6.3.6 to have the latest and do some modelling. The upgrade went fine and the app runs perfectly but something is different and I can't figure it out...

When I right click and look at Table Inspector, everything is as expected with columns, indexes and foreign keys. However when right click and select Alter Table the column list is incomplete, there are no indexes and no foreign keys.

This is only failing since the upgrade but I can't find anything with the config or privileges to get it working. Any help would be greatly appreciated.

*** further observation: If there is no timestamp datatype everything looks fine. However when there is, the alter table window always stops showing columns at the first timestamp and never shows indexes or FK's even though every other approach proves they exist.

  • Have you tried with Workbench 6.2? – Vérace Feb 3 '16 at 2:38
  • Yes 6.2 worked fine. To be clear though, I removed all MySQL from my machine and installed from scratch. I'm guessing it is a config/privilege issue but I can't figure it out. – GolfAddict Feb 3 '16 at 4:36
  • Bug in 6.3.6? Surely not a bug in a newly released MySQL product? Who would have thought? :-) – Vérace Feb 3 '16 at 5:44
  • Someone else would have reported this by now so I assume it is a setup issue. I also did a 'show create table <tablename>' to confirm the schema was correct. Also worth noting that when I reverse engineer to create a model from the existing DB the tables are all there but very few relationships. – GolfAddict Feb 3 '16 at 15:17
1

There seems to be an anomaly or bug when a timestamp column has a default value of CURRENT_TIMESTAMP() - with the parenthesis. 5.7 documentation says it is synonymous with CURRENT_TIMESTAMP but workbench must disagree - sort of.

Changing the definition in workbench by removing the parenthesis provides a message that nothing changed. However changing to "CURRENT_TIMESTAMP ON UPDATE CURRENT_TIMESTAMP" fixes the problems mentioned in the question. And subsequently changing it "CURRENT_TIMESTAMP" only also works.

I'll report this as a workbench 6.3.6 bug.

  • Accept your answer if it resolved your question... geez!! – Pimp Juice IT Mar 29 '17 at 3:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.