0

I've been tweaking the values of the buffer pool size (innodb_buffer_pool_size) and the number of buffer pool instances (innodb_buffer_pool_instances) in the my.ini initialization file to optimize heavy load handling with MySQL. I can successfully change the buffer pool size, both dynamically and with the my.ini file, but no matter what I change the innodb_buffer_pool_instances value to, it is always 1 when I query it with SELECT @@innodb_buffer_pool_instances;

What I've already tried:

  • I made sure to set the buffer pool size > 1GB. I've set it to 24GB and verified that it is indeed that big.

  • Made sure I'm using the correct my.ini file location.

  • After changing the value in my.ini I restart the MySQL server.

  • I've even tried restarting my computer after changing the value, but it still always remains 1.

What am I missing? Why can't I change the value of innodb_buffer_pool_instances?

  • are you using it in windows or linux? Let us know how you identified the ini file. Seem not referring to correct ini file. – Nawaz Sohail Feb 3 '16 at 15:04
  • I'm on Windows 7. That was a problem at first, but I verified that I'm using the right .ini file. I can change the value of innodb_buffer_pool_size, restart the MySQL server, and verify that it's correct. The file location is C:\ProgramData\MySQL\MySQL Server 5.7\myl.ini. – matt Feb 3 '16 at 15:10
  • What version of MySQL? – Rick James Feb 4 '16 at 1:40
  • I'm using MySQL 5.7 – matt Feb 4 '16 at 17:49
0

Fixed it. I just reinstalled MySQL and now the variable updates just like it should. Don't know why it wasn't working, but I don't really care since it works now.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.