0

I an unable to fix this as I don't know what cause this error.

Replication was stoped for maintenance activity and after completing the maintenance we started it and then after some point the replication ended up with the below error:

Last_SQL_Error: Could not execute Delete_rows_v1 event on table rnrinfotech.schedulers_times; Can't find record in 'schedulers_times', Error_code: 1032; handler error HA_ERR_KEY_NOT_FOUND; the event's master log mysql-bin.000093, end_log_pos 896

Both on Centos 6.7:

  • Master Version MySQL-server-5.5.41-1.el6.x86_64
  • Slave1 Version mysql-community-server-5.6.28-2.el6.x86_64
  • Slave2 Version mysql-community-server-5.6.28-2.el6.x86_64

Slave2 is Working fine without any error. I am thinking that can I run multipal slave on my current config.

every time I create secondary slave replication after sync the very next day it get failed with the above reason.

  • Seems a delete event is unable to find it's desired records..See check if you have enabled multi-threaded slave..if so disable it and then start slave. – Nawaz Sohail Feb 4 '16 at 11:10
  • were do we need to check & how? – Mongrel Feb 4 '16 at 11:40
  • show variables like 'slave_parallel_workers' at slave and it should be 0 if no parallel slave is enabled. – Nawaz Sohail Feb 4 '16 at 12:14
  • the output is 0 "slave_parallel_workers 0". I have another slave running perfectly – Mongrel Feb 4 '16 at 12:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.