3

I am working for a critical account and yesterday I got a weird issue after applying cumulative update package 14 on top of SQL Server 2008 R2 Standard edition.

Before applying CU-14 package on the server, I stopped the DB Engine services from Configuration Manager. I started the patching and this finished successfully without any issue and I rebooted the machine too.

The thing is that Services were not coming online even if it was in automatic mode. I started the services and tried to connect and I got an error message:

Server is in script update mode

So I waited for some time because it is in update in progress. After that when I connected to that instance I was getting

network related instance specific error

enter image description here

And interestingly SQL Server services was stopped automatically, again I was trying to start the services and the same scenario is happening repeatedly and I even uninstalled the CU-14 package from the server as well.

As a workaround I included "-T902" flag at the end of the parameters from config manager and started the services successfully and I am able to connect. But running the service by using the flag is not a good workaround.

Still I am experiencing the issue and please suggest: What are the steps we have to perform to resolve this issue?

Thanks for understanding!

migrated from stackoverflow.com Feb 5 '16 at 19:48

This question came from our site for professional and enthusiast programmers.

2

Issue was resolved.. Actually improper build of sql server caused for issue. Check the registry key level for mssql server for what the default data, backup path existing in the host.. Go for same path in the explorer and check whether the database files existing in the same folder.. if not then msagent certificate will be not created in that path.

Eg. Create a sample database in the server without mentioning a physical name then you will get a operating system error saying wrong path.

So after applying the patch also one more msagent certificate will be created showing with version number.. this is the root cause of the issue

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.