5

I am trying to connect 3 SQL servers using SSMS from a different landing server. The issue is I am able to connect 1 server but unable to connect other 2. The error I get is below:

enter image description here

A connection was successfully established with the server, but then an error occurred during the login process. (provider: SSL Provider, error: 0 - An existing connection was forcibly closed by the remote host.)

I am unable to figure out what is wrong with other 2 servers and need your help.

Landing server details:

  1. Windows server 2008 R2 Ent Edition
  2. SSMS 2012 SP1

SQL server details:

  1. SQL Server 2012 -- Able to connect
  2. SQL Server 2012 -- Unable to connect
  3. SQL Server 2005 -- Unable to connect

I am able to ping and telnet all 3 servers from my landing server. Also, tried SQL authentication for 2 servers which I am unable to connect but it didn't work. Disabled TCP chimney, didn't work. The same 3 connections are working fine from my other landing server. So not sure what is wrong with this one. Please help me out to fix the issue.

7

You need to check your SSL and TLS settings.

Check out this KB 3135244. The settings between the client and server should be somewhat consistent (i.e. if the server only allows 1.2 and the client only supports 1.0 I think you might run into issues). Also read through the known issues on that page

Updating to a build that supports TLS 1.2 might resolve your issue.

2

I have the same issue and found it to be related to the certificate not being correct on the sql server.

1

Check the TLS versions on both client and server.

Recently we disabled other protocols and enabled only TLS 1.2 on our SQL Server. We received the same error message when we tried to connect to the SQL Server from our application server.

We then disabled all other protocols and enabled only TLS 1.2 on our application server which resolved our issue.

1

The accepted answer here did not solve my issue.

I had the same issue and was able to resolve it by making sure that the cipher suites and key exchanges were the same on the client(web server) and db server.

You can find a more detailed message in the windows event viewer system log:

Event viewer message

I used IISCrypto to enable the required ciphers:

IIS Crypto Config

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.