1

It's been a little while since I ran mysql dumper, but have done so successfully in the past many times, however when trying now something weird is happening.

I had not changed the settings (I have now after the problem reset to default to try and fix) but now when I run it I'm getting multiple files generated often 1 second after the other as can be seen in this screenshot of the files on the ftp;

enter image description here

I had email confirmation turned on too, and I'm pretty much getting an email sent every second as the interface refreshes.

The interface is showing something like this;

enter image description here

Normally, the last bit (2 seconds, 0 page refreshes) might show something like 40 seconds, 25 page refreshes as it processes bigger databases.

The version of PHP running on the server was updated a little while ago from 5.3 to 5.6.18. Could that have anything to do with this odd behaviour? As I said, the settings had not been changed - even so the default settings are pretty much what I had used anyway.

EDIT

I have also just tried re-downloading mysqldumper from scratch and installing it. Unfortunately, nothing changed. There must be some kind of configuration issue, but I don't know where to find that out...

These are my current settings - they are largely unchanged from the default; enter image description here

If i click auto detect here I get the value 120795955

enter image description here

enter image description here

1
  • I've updated the question with my settings - there are more setting screens, but I've made no changes to them - or everything on them is turned off (FTP for example)
    – Novocaine
    Mar 3 '16 at 14:36
1

Do not OPTIMIZE tables before backups. That consumes a lot of time, thereby making there by more 1-minute dumps. And OPTIMIZE rarely does anything useful.

You have "max file size" = 0 KB -- does that mean unlimited, or small? I see that the files tend to be a few hundred KB.

1
  • The max file size is disabled unless I check multipart backup. I've never used that setting when it worked. However I did test it to see what happened. The same issue occured, only the files had _part_1 or 2,3 etc.. at the end of them in addition to the duplicate small files seconds apart. Turning off the OPTIMIZE option had no effect.
    – Novocaine
    Mar 4 '16 at 9:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.