0

I tried opening my PostgreSQL database and I am getting following error:

An error has occurred:
could not connect to server: No buffer space available (0x00002747/10055) is the server running on "localhost" (::1) and accepting TCP/IP connections on port 5432? could not connect to server : no buffer space avalaible (0x00002747/10055) is the server running on "localhost" (::1) and accepting TCP/IP connections on port 5432?

I have installed PostgreSQL in D drive. I am using PHP on Windows.

How can I solve this problem?

Update:

My PostgreSQL problem was solved the problem how means I installed the PostgreSQL in D drive so, I seriously I checked C drive space there was less memory so, I uninstalled some applications where installed in C drive after restarting my PC automatically started. But one thing we should remember where ever we install the applications like C drive, D drive and so on.. but that application acquire the C drive buffer space so, in C drive minimum space is required memory is up to 5 GB then we won't get any application error.

  • Here postgresql.org/message-id/565F334E.2040603@griensu.com they say the issue might be Antivirus software on your PC. – til_b Feb 26 '16 at 10:34
  • Have you checked your memory settings? – dezso Feb 26 '16 at 11:22
  • 1
    Get Process Explorer from sysinternals.com (now owned by Microsoft) and check memory stats. Just noticed "D drive". Go to sysinternals. – Vérace Feb 26 '16 at 18:45
  • Reboot your database server and give it 10 minutes to settle. Then check memory usage. If possible turn off any service that is not essential. Using the programme that I mentioned, check that PostgreSQL is in fact running. Then try an use the server. – Vérace Feb 28 '16 at 5:09
2

No buffer space available corresponds to a network error where the client is not enable to allocate the resources to initiate a connection.

Generally, this means that there are other programs holding too many connection handles (sockets).

According to a post on IBM developerWorks:

This error can occur on Windows, particularly around socket operations. The error is translated from the Winsock error code WSAENOBUFS, 10055. The most common cause of this error is that Windows is configured for the default maximum of 5,000 in-use ports. This can be monitored by watching netstat or perfmon and can be changed with the MaxUserPort registry parameter.

A more advanced cause for this error is non-paged pool exhaustion[...]

Uninstalling software will solve the problem for good only if that software was responsible for consuming too many simultaneous connections in the first place. Otherwise, getting back some of these resources may happen as a side-effect of say, rebooting, or just waiting a bit so that TCP connections in TIME_WAIT state disappear, or individually terminating programs that held these connections open.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.