1

I've duplicated our production to our UAT environment several times in the past but due to various reason, this time has been a serious PITA. Oracle 11.2.0.3.
We have a recovery catalog setup. This is the script thats run on the UAT box:

connect catalog rman/cat@rc  
connect auxiliary /  
run {  
ALLOCATE AUXILIARY CHANNEL aux1 DEVICE TYPE DISK;  
ALLOCATE AUXILIARY CHANNEL aux2 DEVICE TYPE DISK;  
ALLOCATE AUXILIARY CHANNEL aux3 DEVICE TYPE DISK;  
ALLOCATE AUXILIARY CHANNEL aux4 DEVICE TYPE DISK;  


duplicate database RACDB01 to GVPUAT skip tablespace  
TS_ADMIN2,TS_ERROR_ERRORLOG,...
<big list of tablespaces I don't care about>...,RADSS_WG_INDEX_LARGE   
NOFILENAMECHECK until time "to_date('2016-03-02 00:00:00','YYYY-MM-DD HH24:MI:SS')";  

The problem is it errors with RMAN-06023: no backup or copy of datafile 352 found to restore. This is because on 03/01/2016 I added a datafile to production. A backup was started on production at 12pm, I added a datafile at 6 pm, and the backup finished at roughly 11pm. How can I use that backup?

1 Answer 1

2

Try just backing up the tablespace for the new datafile. Then as long as you have all of the archive logs that were generated since the last backup, your clone should work.

2
  • Hmm will try that.
    – rfusca
    Mar 2, 2016 at 16:40
  • Its a bug - MOS note 782317.1 . Your suggestion is one of the fixes.
    – rfusca
    Mar 2, 2016 at 18:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.