1

I am having problems to get one database running. I have a MySQL in my server, the server is running "5.5.48-MariaDB - MariaDB Server" with "UTF-8 Unicode (utf8)"

I have a MySQL ODBC 64 bits 3.51 Driver to be able to connect to this database. The ODBC is configure to use utf8 character set.

If I use for example MySQL workbench to connect to this database for example:

SELECT * FROM leomaker_prueba_01.Capacitor;

All is perfect, I get the data. Also work with:

SELECT DISTINCT PartType FROM Capacitor ORDER BY PartType

I think that this is the correct form to make query of this kind.

The problem start with my program: "OrCAD Capture Cis". This program make a connection to a Database to fetch data and use it in the program.

In the console of the program I get this error:

ODBC Error Description: State:S0001,Native:1050,Origin:[MySQL][ODBC 3.51 Driver][mysqld-5.5.48-MariaDB] SELECT DISTINCT "PartType" FROM "Capacitor" ORDER BY "PartType" ERROR(ORCIS-6245): Database Operation Failed Please Check Session For More Details ERROR(ORCIS-6250): ODBC Error Code: -1 Description: You have an error in your SQL syntax; check the manual that corresponds to your MariaDB server version for the right syntax to use near '"Capacitor" ORDER BY "PartType"' at line 1

As we see the query that it makes is

SELECT DISTINCT "PartType" FROM "Capacitor" ORDER BY "PartType"

Which is incorrect. I also try it in MySQL Workbench and i get the same kind of errors. I am sure that is problems of the " symbols.

The default database connect to a local SQL server. (but i can't see the querys)

Which could be the problem? I try to use MariaDB ODBC and i get the same error. Also if I try to change of character set.

It could be any form to change the querys to the database?

Thanks

  • 1
    The query is correct, in ANSI mode. In ANSI mode, table and column names can be quoted with with double quotes ". In the default (non ANSI mode), table and column names can be quoted with backquotes ` and double quoted strings are taken as string literals. – ypercubeᵀᴹ Mar 11 '16 at 8:49
2

Solved, the problems was the ODBC connector. I have to use the ODBC MySQL 5.1 instead of 3.5, due to my MySQL server uses 5.5.

This solve the problem with the "

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.