7

I'm a developer working on a web application using an instance of SQL Server 2014. I use Visual Studio 2010 sp1 for development. For a task I'm currently working on, I'd like to use the SQL Server Remote Debugger to debug a very large stored procedure that we call through our ORM (Entity Framework). To do this, I open SQL Server Management Studio 2014 and type the following into a new query window:

EXEC [dbo].[MoveAllInvoiceStage]

and when I press the Debug button, I receive the following error:

===================================

Failed to start debugger

===================================

Data is Null. This method or property cannot be called on Null values. (System.Data)

------------------------------ Program Location:

at System.Data.SqlTypes.SqlBinary.get_Value() at Microsoft.SqlServer.Management.UI.VSIntegration.DebugSession.DebugCallbacks.OnSqlInitializeDebuggingEvent(ISqlInitializeDebuggingEvent sqlInitializeDebuggingEvent) at Microsoft.SqlServer.Management.UI.VSIntegration.DebugSession.DebugCallbacks.Microsoft.VisualStudio.Debugger.Interop.IDebugEventCallback2.Event(IDebugEngine2 debugEngine, IDebugProcess2 debugProcess, IDebugProgram2 debugProgram, IDebugThread2 debugThread, IDebugEvent2 debugEvent, Guid& riidEvent, UInt32 attribute)

Which is followed by a dialog that says:

Unable to start program 'MSSQL:://<servername>/<databasename>/sys/=0'.

I am using a Windows login with a sysadmin role to connect to the database server, and all necessary firewall rules are in place on the server and my PC. I ensured that the requirements listed here are met.

The remote debugger was working when the database server hosted a SQL Server 2008 R2 instance, but it seems that it stopped working after upgrading the instance to SQL Server 2014. I can still debug on my local SQL Server 2014 instance (which hosts a copy of the remote database). Only remote debugging produces this issue.

I have confirmed that another developer on a different PC is experiencing the same issue, so the problem seems to be server-side.

Are there any additional steps I can take to troubleshoot this issue?

  • Did you ever solve this? – twoLeftFeet Jan 30 '18 at 21:41
  • @roemhildtg No I did not. I finally discovered the root issue of the task I was working on, and since then have not needed to use remote debugging in SSMS. – Garrett Bates Mar 2 '18 at 19:12
  • 1
    We did a repair install and it worked for us. – twoLeftFeet Mar 3 '18 at 8:32
1

I had this exact problem, and solved it, on my local dev machine, by reinstalling a Visual Studio update.

I use 2012 SQL Server and VS 2015.2. This is all Localhost - no remote debugging.

Problem occurred after installing SSMS 2016 RC3. Debugging in SSMS 2016 caused the above error.

SSMS 2014 worked just fine.

The problem went away when I reinstalled (Repaired) the VS2015.2 update.

Each SSMS version has a VS Isolated Shell version it uses. (SSMS 2016 uses VS2015, SSMS 2014 uses VS2012 etc)

It would seem there was some sort of version conflict between the SSMS installation's VS Isolated Shell, and the full VS installation. Maybe the VS update has something to do with it.

Anyway, hope this helps somebody.

protected by Community Jan 18 at 18:55

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.