There are multiple issues with a server I manage, we cannot start management studio on it and when we try to install patches to SQL Server the setup never shows up.

I run the patch as an administrator, it shows me that some files are being extracted to a temp folder, then a CMD window opens for a split second and closes immediately after.

I have looked around a bit to find a solution but can't quite decide where to start from.

Here is a link of someone saying he ran caspol.exe to fix a somewhat similar issue

What's caspol anyways? Having never used it I don't really want to create more issues by not knowing what it should be used for.0

Here is another link saying I need to add registry keys for my installation to begin:

Here is my server's select @@version query result :

Microsoft SQL Server 2008 (SP1) - 10.0.2531.0 (Intel X86) Mar 29 2009 10:27:29 Copyright (c) 1988-2008 Microsoft Corporation Standard Edition on Windows NT 6.0 (Build 6002: Service Pack 2) (VM)

The server is a windows server 2008 32-bit

The patch setup creates the following log when it fails :

03/17/2016 13:58:13.308 ======================================================================
03/17/2016 13:58:13.309 Setup launched
03/17/2016 13:58:13.310 Attempting to determine media source
03/17/2016 13:58:13.311 Media source value not specified on command line argument.
03/17/2016 13:58:13.390 Setup is launched from media directly so default the value to the current folder.
03/17/2016 13:58:13.391 Media source: g:\e89cdf338f18c1307f\
03/17/2016 13:58:13.391 Attempt to determine media layout based on file 'g:\e89cdf338f18c1307f\mediainfo.xml'.
03/17/2016 13:58:13.433 The folder 'g:\e89cdf338f18c1307f\' does not contain a valid media info file 'mediainfo.xml'.
03/17/2016 13:58:13.434 Setup closed with exit code: 0x84C4001E
03/17/2016 13:58:13.484 ======================================================================

It might be good to add that the windows search is not working, as you may observe in the following image :

non-working windows search

Maybe the setup is trying to look for files but fails as it cannot search for them ?

If this was your server, what would be the first step of troubleshooting you'd go through ?

  • 2
    The first thing would be to wipe it and get rid of whatever Win9x operating system that is. How many decades before this person becomes interested in a fresh start? Commented Mar 17, 2016 at 19:19
  • This server is part of a very wide farm and the person that created it has left for retirement years ago. My take on this would also be to wipe it, be it my choice.
    – A_V
    Commented Mar 17, 2016 at 19:21
  • Why do you need Management Studio on that server? Commented Mar 17, 2016 at 19:24
  • I do not, I can login from elsewhere easily but I do need to install patches there and they do not start. As stated in the post the setup starts, shows it's extracting temp files and then open a CMD prompt that closes immediately.
    – A_V
    Commented Mar 17, 2016 at 19:26
  • 1
    I wonder if you could try and install the patches via the command line from the server, similar to this: <package_name>.exe /qs /IAcceptSQLServerLicenseTerms /Action=Patch /AllInstances
    – rvsc48
    Commented Mar 17, 2016 at 19:49

1 Answer 1


Here is a good place to start: https://support.microsoft.com/en-us/kb/969052

I ran into a similar issue as you and this allowed me to fix it. The script on that page ended up showing me all the items that needed to be fixed. In my case, the original install happened over a network share, which no longer existed. Using the output from the script, I manually copied the items to the local Windows installer cache.

Here is example of output of what it found that I did not have to fix:

PRODUCT NAME   : SQL Server 2008 R2 SP2 BI Development Studio
  Product Code: {312E8540-0799-45D5-A02E-DFB8FCA93CCA}
  Version     : 10.53.6000.34
  Most Current Install Date: 20151113
  Target Install Location: 
  Registry Path: 
     Package    : sql_bids.msi
  Install Source: \x64\setup\
  LastUsedSource: n;1;\\server\with\path\that\no\longer\exists\SQL Server 2008 R2 Enterprise\x64\setup\

 !!!! sql_bids.msi DOES NOT exist on the path in the path \\server\with\path\that\no\longer\exists\SQL Server 2008 R2 Enterprise\x64\setup\ !!!!

 Action needed, re-establish the path to \\server\with\path\that\no\longer\exists\SQL Server 2008 R2 Enterprise\x64\setup\

Installer Cache File: C:\Windows\Installer\12b7423e.msi

    Package exists in the Installer cache, no actions needed.
    Any missing packages will update automatically if needed assuming that
    the LastUsedSource exists.

    Should you get errors about C:\Windows\Installer\12b7423e.msi or \\server\with\path\that\no\longer\exists\SQL Server 2008 R2 Enterprise\x64\setup\sql_bids.msi then you
    may need to manually copy the file, if file exists replace the problem file, 
    Copy and paste the following command line into an administrative command prompt:

     Copy "\\server\with\path\that\no\longer\exists\SQL Server 2008 R2 Enterprise\x64\setup\sql_bids.msi" C:\Windows\Installer\12b7423e.msi

For that item, I did nothing. However, here is an example of something that it needed:

SQL Server 2008 R2 SP2 Database Engine Shared Patches Installed 
 Display Name:    GDR 1617 for SQL Server Database Services 2008 Core Shared (64-bit) (KB2494088)
 KB Article URL:  http://support.microsoft.com/?kbid=2494088
 Install Date:    20120227
   Uninstallable:   1
 Patch Details: 
   PackageName:   sql_engine_core_shared.msp
    Patch LastUsedSource: n;1;c:\be3c4c3dfe15678dec7048ab989c4f\x64\setup\sql_engine_core_shared_msi\
   Installer Cache File Path:     c:\Windows\Installer\f696075.msp
     Per SOFTWARE\Microsoft\Windows\CurrentVersion\Installer\UserData\S-1-5-18\Patches\17817DD65FBE36A47AA93B8ADF0CE829\LocalPackage

!!!! c:\Windows\Installer\f696075.msp package DOES NOT exist in the Installer cache. !!!!

     Action needed, recreate or re-establish path to the directory:
       c:\be3c4c3dfe15678dec7048ab989c4f\x64\setup\sql_engine_core_shared_msi\ then rerun this script to update installer cache and results
     The path on the line above must exist at the root location to resolve
     this problem with your msi/msp file not being found or corrupted,
     In some cases you may need to manually copy missing files or manually
     replace the problem file, 

     Copy "c:\be3c4c3dfe15678dec7048ab989c4f\x64\setup\sql_engine_core_shared_msi\sql_engine_core_shared.msp" c:\Windows\Installer\f696075.msp

     Replace the existing file if prompted to do so.

     Use the following URL to assist with downloading the patch:

As you can see, it tells you what to copy and where to copy it to. In my case, I ignored the source location and just copied the listed files from a known good installation location (iso, installation media, local folder, or whatever has the installation files for that version of SQL Server). After that, I was able to finish patching SQL Server to the point where I could then install the latest service pack.

The difference between the two items above is the first one, even though it cannot find the file in the original location, the file is in the local Windows Installer cache where as in the second one, the original location does not exist AND the file is not in the windows installer cache.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.