0

I'm trying to figure out how to do a rolling upgrade of our galera cluster running on MariaDB on Ubuntu 14.04. In testing, the first node I upgraded started complaining about the timestamp column in mysql.innodb_table_stats having the wrong type, INT vs Binary(4). I then tried an actual un-install -> install type upgrade, and it seemed to work until it connected to the cluster, and then it started with the same error as before. All the documents that I've found talk about this process on a standalone server, but not one that is part of a cluster.

I did look over this similar post, but, in the first comment, you can see that Ubuntu does it just enough differently, that I'm not sure how to do this.

Any Ideas? Thanks

  • Did you run mysql_upgrade? I would expect the timestamp column to be datatype TIMESTAMP. – Rick James Mar 26 '16 at 0:14
  • 1
    No I didn't. On Ubuntu mysql_upgrade is done by the repo package upgrade. – Aaron Mar 28 '16 at 16:22
  • Can I run mysql_upgrade again, or does that cause problems? – Aaron Mar 28 '16 at 17:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.