0

Our partner has created a new database to us so we can use it as a test database. He gave us all addresses and connection information so we can use it to connect to the database.

I've asked here how to add a catalog to the database so we could connect to it and it work as it should.

After connecting to it we could not run any command always getting same error: We try to run:

create table test (id integer)

SQL0551N "MY_USER" does not have the required authorization or privilege to perform operation "EXECUTE" on object "NULLID.SQLC2H23". SQLSTATE=42501

And then we called to our partner telling him that and he send a screenshot executing same command and it work as it should.

I think that it worth to mention that he is at the terminal on the server and we are from our machine on the db2 client console.

So, is there any permission or authorization or grant that he should add to our MY_USER user so we can run anything on it?

The strange thing is that when we connect with the same user on the TOAD client all commands works as it should. So my wild guess is something to do with the catalog we created.

  • 1
    It's likely caused by the version mismatch between the client and server. See this: stackoverflow.com/a/36312148/1227152 – mustaccio Mar 30 '16 at 21:21
  • @mustaccio it seems You are right, again, I run the db2 client from inside TOAD installation and it work all ok. My installed client is 9.7.6 and the TOAD's is 10.1.3. So if you add it as an answer I will promptly accept it. Thank you once again. – Jorge Campos Mar 30 '16 at 23:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.